Displayed time wrong,

When I set the system time via
$ sudo date +%T -s “12:34:00”

and then reboot, the time i get displayed returns to the previous wrong time…
the time in the bios is ok, and i am set to the correct time zone, so i guess i am missing something else here?
it all started after my bios battery was empty and needed to be replaced…

thank you!

You can setup time in msm.

1 Like

Hi @kalimerox,

Sounds to me like your locale is messed up. Have a look here:



1 Like

thank you both I will try your suggestions!

1 Like

Do you have a dual boot system Linux/Windows ?

1 Like

That depends on what you mean with wrong time - are you seeing 12-hour format or 24-hour format and which one are you expecting?

Or is the clock outright wrong e.g. 10:34 when it should be 12:34?

Does your /etc/localtime symlink to the correct timezone?

$ ls -l /etc/localtime
lrwxrwxrwx 1 root root 37 12 mar 13:23 /etc/localtime -> /usr/share/zoneinfo/Europe/Copenhagen

Did you enable the ntp client

systemctl enable --now systemd-timesyncd

Dualbooting windows requires special care

1 Like