Display Skalierung Gnome mit X11

Hallo Leute

Habe noch ein kleineres Problem damit meine Convertible den letzten feinschliff bekommt . Normaler weise kann ich durch den Befehl : gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']" verschieden Skallierungen freischalten . Dies klappt hier leider unter der aktuellen Gnome Version nicht . Ich hatte auch mal : gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']" ausprobiert , aber das ist ja für Wayland . echo $XDG_SESSION_TYPE : X11 also kann das ja auch nicht funktionieren . Hat jemand eine Idee wie ich dies aktivieren kann in den Gnome Settings ? Möchte es nicht übers Terminal machen , da ich gerne mal zwischen 100% & 150% wechseln würde . Jenachdem ob ich mein Gerät als Notebook oder Tablet nutze .

1 Like

Das funktioniert nur unter Ubuntu. Wird von denen rein gepatcht.

Gibt es einen Grund warum du Wayland nicht verwenden willst. Also z.B. eine Nvidia Karte.

Wenn du nur X11 verwenden kannst, steht im Arch Wiki wie es trotzdem klappen könnte. Hört sich allerdings nicht so super einfach an.
https://wiki.archlinux.org/index.php/HiDPI#Fractional_Scaling

1 Like

Ups erwischt komme von Ubuntu zu euch :smiley: dachte es wäre standard unter Gnome . Gegen Wayland spricht bei meinem Hardware setting nichts , ist halt standard das es bei Manjaro mit X11 läuft . Wie Wechsel ich dies denn ? Also von X11 zu Wayland und ist dann eine erweiterte skallierung standard ? Sry für so viele Anfänger fragen .

Kein Problem.

Es gibt noch ein paar mehr Gründe warum nicht jeder Wayland mag. Aber am besten selbst ausprobieren.

Um Wayland benutzen zu können musst du nur eine Datei anpassen.

gedit admin:/etc/gdm/custom.conf 

Dort kommentiere die Zeile WaylandEnable=false aus. Also mache ein # davor. Dann einfach speichern und neu starten. Bevor du dich anmeldest, kontroliere ob die richtige Session ausgewäglt ist. Nachdem du auf deinen Namen geklickt hast, sollte auch ein kleines Zahnrad erscheinen. Stelle sicher das dort Gnome ausgewählt ist und nicht Gnome on Xorg (könnte im deutschen anders heißen).

Nein, das ist auch unter Wayland noch eine experimentelle Funktion. Aber mit

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

und ggf. einem Neustart sollte es klappen.

3 Likes

Vielen Danke für deine tolle Hilfe , hat super geklappt :slight_smile: Tolles Forum , fühle mich immer wohler bei Manjaro . Habe mich wohl nicht nur für ein Tolles OS entschieden , sondern auch für eine Klasse Community .

1 Like

Dank diesem Thread bin ich neugierig geworden und habe Mutter mit dem Ubuntu Patch kompiliert.
Die Skalierung funktioniert bei mir unter X11 nach Aktivierung via:

gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']"

Wer möchte kann das Paket hier herunterladen und testen, aber seid gewarnt das es auf der Unstable Branch gebaut wurde und ich keine Garantie überneheme. :wink:

@pux Thank you so much for providing this patch.
I do really need to perform a fractional scaling for my case.
Could you please give detailed instructions on how to install it (excuse me my inexperience). Many thanks again.

Since the binary package from @pux is for the unstable branch, you might want to rebuild mutter for your branch. It is kind of easy.

Make sure you have the base-devel and git package installed.

sudo pacman -Syu base-devel git

Then do

git clone https://github.com/puxplaying/mutter-x11-scaling.git
cd mutter-x11-scaling
makepkg -srci 

The last command should install the dependencies, build mutter with the patch and install the package. After a successful build, it will also remove the build dependencies. It might take a while, depending on your system.

The original PKGBUILD form @pux can't be easily be used with makepkg, so I did a fork.

--
changes merged back, use the original repo.

2 Likes

@xabbu Thank you for your reply.

sudo pacman -Syu base-devel git
asks me to enter a selection. Which one should I select for this purpose?

:: There are 26 members in group base-devel:
:: Repository core
   1) autoconf  2) automake  3) binutils  4) bison  5) fakeroot  6) file
   7) findutils  8) flex  9) gawk  10) gcc  11) gettext  12) grep  13) groff
   14) gzip  15) libtool  16) m4  17) make  18) pacman  19) patch  20) pkgconf
   21) sed  22) sudo  23) systemd  24) texinfo  25) util-linux  26) which

Enter a selection (default=all): all

Many thanks again

all is the correct selection.

1 Like

@xabbu
Thanks a lot.
I am then asked the following:

==> Cleaning up...
==> Removing installed dependencies...
checking dependencies...

Packages (11) egl-wayland-1.1.4-1
              eglexternalplatform-1.0+3+g7c8f8e2-1
              gobject-introspection-1.62.0-1  meson-0.52.0-1
              ninja-1.9.0-1  python-beaker-1.11.0-1
              python-mako-1.0.14-1  python-markdown-3.1.1-2
              python-markupsafe-1.1.1-1  sysprof-3.34.1-1
              xorg-server-xvfb-1.20.5-2.1

Total Removed Size:  23,76 MiB

:: Do you want to remove these packages? [Y/n] 

Shall I remove them or not ? Many thanks

Well, that depends. These packages are build dependencies. You only need them to build the mutter package. These packages are not required to use the mutter package. However, every time you build mutter you have to install these packages.

If you know that you will often build mutter you can keep the packages. But the makepkg command will install these packages again, if you choose to remove them.

1 Like

@xabbu
Ok, thank you so much for the explanation :slightly_smiling_face:
So, I did not remove them in the end.
But I have received this error:

==> Cleaning up...
==> Removing installed dependencies...
checking dependencies...

Packages (11) egl-wayland-1.1.4-1
              eglexternalplatform-1.0+3+g7c8f8e2-1
              gobject-introspection-1.62.0-1  meson-0.52.0-1
              ninja-1.9.0-1  python-beaker-1.11.0-1
              python-mako-1.0.14-1  python-markdown-3.1.1-2
              python-markupsafe-1.1.1-1  sysprof-3.34.1-1
              xorg-server-xvfb-1.20.5-2.1

Total Removed Size:  23,76 MiB

:: Do you want to remove these packages? [Y/n] n
==> WARNING: Failed to remove installed dependencies.

==> ERROR: An unknown error has occurred. Exiting...
User defined signal 1

The -r option of makepkg will remove build dependencies. Maybe makepkg doesn't like the no answer at this point.

However, makepkg installed the new mutter package in the step prior to that. So you can reboot and test it.

1 Like

@xabbu Many thanks.

Let me just explain that I was looking for this feature because I am running Manjaro on a 14'' Lenovo T490,
who has a WQHD (2560x1440), IPS screen:

inxi -Fxxxz
System:
  Host: david-pc Kernel: 5.2.20-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: Gnome 3.34.1 wm: gnome-shell dm: GDM 3.34.1 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20N2S1PE00 v: ThinkPad T490 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20N2S1PE00 v: SDK0R32862 WIN serial: <filter> 
  UEFI: LENOVO v: N2IET75W (1.53 ) date: 08/21/2019 
Battery:
  ID-1: BAT0 charge: 51.3 Wh condition: 52.0/50.5 Wh (103%) 
  volts: 13.0/11.5 model: SMP 02DL008 type: Li-poly serial: <filter> 
  status: Unknown cycles: 2 
CPU:
  Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: C L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 31880 
  Speed: 600 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 600 2: 600 
  3: 600 4: 600 5: 600 6: 600 7: 600 8: 600 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3ea0 
  Display: x11 server: X.org 1.20.5 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics (Whiskey Lake 3x8 GT2) 
  v: 4.5 Mesa 19.2.1 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9dc8 
  Sound Server: ALSA v: k5.2.20-1-MANJARO 
Network:
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi 
  v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:9df0 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: 3.2.6-k 
  port: efa0 bus ID: 00:1f.6 chip ID: 8086:15be 
  IF: enp0s31f6 state: down mac: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 7.96 GiB (1.7%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L7 
  size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: 4M2QEXF7 scheme: GPT 
Partition:
  ID-1: / size: 442.97 GiB used: 7.96 GiB (1.8%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: swap-1 size: 25.59 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 226 Uptime: 23m Memory: 23.27 GiB used: 1.79 GiB (7.7%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: gnome-terminal inxi: 3.0.36 

On this built-in 14'' screen, every icon and window were originally running very small at 100% under Settings > Displays.
Changing the size to 200% made everything perfectly OK in size.

However, when I connect to a 27'' display, whose resolution is the same as the screen laptop, 2560 x 1440, I see things very small.
I've selected the Scale to 200% for the 27'' display, but things were brutally big on the 27''.

Hence, this was the motivation for a fractional scaling, targeted to the external 27'' display.

I rebooted, applied the gsettings command, and Gnome Displays could be re-scaled to 125%, 150% and 175%. In the three cases, all fonts (e.g. manjaro menus and firefox) are blurry on the external monitor. I wonder if this can have a solution ?

@David1
Sorry I'm late to the party but @xabbu already provided all the help better than i could've done!
I didn't really need this patch since I don't have a monitor where I could use it, but was curious to see if it works and so I compiled it.

Did you try to restart the shell after applying the scaling via Alt+F2+r ?
Not sure what could cause that blur as I can't test it.

@xabbu @pux Again, thank you both. Not Alt+F2+r, but I restarted the system.

In order to show this, I have tried to take screenshots, but unfortunately when the png is opened, as expected, since it's a screenshot, the photo is smooth and this blurriness on the fonts cannot be seen -

I cannot think of other way of sharing my end result - would it be possible if you could test this as well ? Thanks again

Hallo @Linows @David1

Ich habe eine aktualisierte Version von mutter online gestellt mit dem Ubuntu Patch für Xorg Skalierung. Das Paket wurde auf der Stable Branch gebaut und kann hier heruntergeladen werden.

Alternativ kann man es auch wie von @xabbu oben beschrieben selbst kompilieren:

sudo pacman -Syu base-devel git
git clone https://github.com/puxplaying/mutter-x11-scaling.git
cd mutter-x11-scaling
makepkg -srci

Vielen Dank an @xabbu für die Hilfe am PKGBUILD ! :handshake:

Da es zumindest bei mir zu funktionieren scheint und ich noch keine Probleme bemerken konnte, werde ich versuchen das Paket weiterhin zu pflegen und hoffe dass es auch für andere nützlich ist.

Viel Spass!

Forum kindly sponsored by