Display Settings Disappeared After Failed Update Attempt - Display Now Rotated


Hope someone can please advise about issues with my little One Netbook One Mix Yoga 3S laptop running Manjaro 21.3.1 Cinnamon.

Did a Manjaro update using Package Manager. However, it tried to do a build of Electron 9. Didn’t realize at first that build had a list of 32000+ items to do! Had to leave laptop running overnight to complete. However, next morning, I saw various errors, so, build did not complete.
Shut down laptop.
Next day, started laptop and noticed that the login screen was rotated sideways. Logged in and desktop screen was rotated sideways. Tried to open the Display settings app to reset display rotation, but the app has disappeared!

Only way I could rotate display was in terminal and doing

$ sudo xrandr -o left

Here’s inxi output:

$ inxi --admin --verbosity=7 --filter --width
CPU: dual core Intel i7-8500Y (-MT MCP-)
Speed/min/max: 800/400/4200 MHz
Kernel: 5.14.18-1-MANJARO x86_64 Up: 43m
Mem: 1298.4/15917.0 MiB (8.2%)
Storage: 476.94 GiB (4.7% used) Procs: 177 Shell: Bash 5.1.16
inxi: 3.3.19

Just noticed the kernel version changed to newer one during update.

Any suggestions how to restore the Display settings app and fix any damage done to system from the failed updating process?

I don’t have any backups for this laptop. So, that’s not an option.

Thank you for any and all help!


I also have same problem, interestingly display manager completely disappeared.

Did you also do an update before this happened?

If so, then there’s clearly a problem with the recent updates.

Exactly, this is the reason. I opened the issue on GitHub.

There are far more knowledgeable people on here than me so I might be wrong. It looks like you are running kernel 5.14 which isn’t supported anymore and maybe responsible for some of the errors. I’d install a lts kernel like 5.15 and remove 5.14 then try and run a system update again see what happens then

@maxemilian Great!

@sawdoctor Thanks for the advice…will try it.

Has anyone had progress or success resolving this issue yet? I had the same issue - ran an update and now my Display menu option has disappeared. Monitors have reset to just display the laptop, not the three external monitors normally used. Can turn on an external monitor with Xrandr. Running Manjaro Cinnamon. Have also updated the Kernel to 5.15 (LTS) and the issue persists.

Not yet for me, @GroovyBloke

In fact, I decided to reinstall Manjaro Cinnamon with a new downloaded file.

Installed OK and then changed display orientation with the Display app.

Unfortunately, after I shut down and then restarted, the Display app disappeared just like before!


So, it’s clearly a bug with Manjaro.

Thank you for your reinstall efforts and troubleshooting anyway, @ArchiMark

As of updating today, this issue has been resolved for me. I now have the Display app available again.