Display Server not running on boot

Hi Manjaro community,

This week I made an update in my manjaro and after the update, when booting, instead of starting the display server and go to a login window there is no more signal to the monitor.

I entered in the command line mode and startxfce4 with success. So my believe is that during boot the .xinitrc is not being called automatically.

What do you think? Do you have some hints on how I can proceed my investigation?

Thank you.

Hi @tcr, and welcome!

That sounds a bit funky.

I’d recommend booting into a Live ISO environment, using a USB stick or something in the line of that which you would usually use to install Manjaro.

Once it has booted, open a terminal and enter a chroot environment using sudo:

sudo manjaro-chroot -a

If asked for the password, the password on the ISO image is manjaro, IIRC.

Depending on the age of the ISO image as well as your setup, manjaro-chroot might as you to select which install to use. if the one selected doen’t work, try one digit lower than it’s option.

Once sucessful, be careful as you are now root on your actual installation.

Now, in the chroot environment, update your system to sync it to working settings again.

pamac upgrade --enable-downgrade

Follow the prompts, and when done exit the chroot environment and reboot to see if it worked.

If it worked, feel free to heap on the praise. If it doesn’t, well, then I’m off and not available.

Hope it helps!

Are you on an AMD graphics?

Check the journal and any (possibly failed) services.

If you happen to be running ADM graphics, have a look at this post. GDM does not start until I switch tty,


Thank you for your reply.
When booting I can enter in grub command line and change the boot to command line only. After that the startxfce4 works fine.

I tried to use a usb drive with the latest manjaro, after the boot I also don’t have the manjaro display. This makes it hard enough that I cannot even install manjaro again, at least from a GUI.

I am using nvidea gt218.

Hi all,

I made a few more experiences.
I updated a laptop without any issue. I used the usb boot image to boot in a laptop with success.

With the usb boot image in the desktop it simply does not work.
I installed manjaro 20 without any issue.
Then I updated the system with exception for all nvidia drivers. The system crashes again. Even the shortcut to change to tty is not available.
Downgraded the kernel and also doesn’t work.

I checked the journalctl I have a core dump from the light locker. Any ideas?

Currently I don’t have any more ideas :(.