Display Resolution Scaling

What should be the display scaling of a 15.6 inch 1920*1080 (Full HD) laptop display? I am on Manjaro gnome and everything seems a little small, especially websites. Using amd open source graphics driver (I think it is on hybrid mode). Hp Omen 15 2020 (Ryzen 5 4600H & GTX 1660 Ti). Scaling is probably 125% on windows 11.

KDE/QT Scalling 120 dpi
GNOME/GTK 1.2

Firefox/Thunderbird
In about:config set layout.css.devPixelsPerPx to 1.2 value.

Chrome or other chromium based (they have another config file names. See PKGBUILD code package for details.)

$HOME/chrome-flags.conf

--flag-switches-begin
--high-dpi-support=1
--force-device-scale-factor=1.2
--flag-switches-end

ENVIROMENT
Add to file /etc/enviroment

GDK_SCALE=1.2

Reboot for apply changes.

Spotify in desktop file Exec need:

Exec=spotify --force-device-scale-factor=1.2 %U

instead of default.

1 Like

Thank you

In gnome-control-center there is a option for fractional scaling. If i set 125% there, everything seems file (a bit large 2 b honest, 120% would b fine but there is no option for 120%).

Can I set 120 scaling on the entire os? 125 seems a little large.

GDM is not scaling to 125%, it is still 100% & everything is very tiny. How to fix gdm scaling?

Try HiDPI scale does not apply to login screen? - #3 by bright - Ask Fedora

1 Like

cp ~/.config/monitors.xml /var/lib/gdm/.config/

This solved the issue… I had to enable fractional scaling for gdm in x11 first.

I have set 125% scaling in gnome-control-center & nothing else. Everything is looking normal now though I think it is a little large.

Cause better is 120 dpi, not 125 based on Win.doze. :wink:

For future:

KDE SDDM

/etc/sddm.conf.d/hidpi.conf
with code inside

[Wayland]
EnableHiDPI=true

[X11]
ServerArguments=-nolisten tcp -dpi 120
EnableHiDPI=true

/etc/sddm.conf.d/kde_settings.conf

[Autologin]
Relogin=false
Session=
User=

[General]
HaltCommand=/usr/bin/systemctl poweroff
Numlock=none
RebootCommand=/usr/bin/systemctl reboot

[Theme]
Current=breeze
CursorTheme=breeze_cursors

[Users]
MaximumUid=60000
MinimumUid=1000

[X11]
ServerArguments=-dpi 120

IN KDE enviroments variables should be put in sh file:
$HOME/.config/plasma-workspace/env/ envars.sh

#!/usr/bin/bash
export BROWSER="/usr/bin/xdg-open"
export EDITOR="/usr/bin/nano"
export GCC_COLORS="auto"
export GDK_SCALE=1.2
export JAVA_FONTS="/usr/share/fonts/TTF"
export KDE_FULL_SESSION=true
export KDE_SESSION_VERSION=5
export QT_LOGGING_RULES='*=false'
export PATH="$HOME/bin:$PATH"
export SSH_ASKPASS="/usr/bin/ksshaskpass"
export SSH_AUTH_SOCK="$XDG_RUNTIME_DIR/ssh-agent.socket"
export SYSTEMD_COLORS=1
export VISUAL=$EDITOR
export _JAVA_OPTIONS="-Dawt.useSystemAAFontSettings=lcd_hrgb -Dswing.aatext=true"
export COGL_ATLAS_DEFAULT_BLIT_MODE=framebuffer

for working these proper zsh file or bash CONFIG file (.bashrc or .zshrc) should be added line

[ -f $HOME/.config/plasma-workspace/env/envars.sh ] && . $HOME/.config/plasma-workspace/env/envars.sh

Reference Session Environment Variables – KDE UserBase Wiki

So can you please tell me how can I do 1.20 scaling instead of 1.25 in Gnome?
Options are 125% 150% 200%…

HiDPI - ArchWiki (archlinux.org)

GNOME is hardcoded. Read linked article wiki with care.

1 Like

Hey I just checked in Windows 11, the recommended scaling is set to 125% there.

I know :wink: But Windows using another scalling technology and in results GUI is not that big instead of Linux DE.

HiDPI on Gnome desktop (valhalla.fr)

Your call if you stay with 125 or trying 1.2

1 Like

Anything other than 125/150/200 is looking a little blurry. So I am sticking with 125% scaling. Compared some websites with Windows 11 & everything is looking almost similar.

Is it looking fine?

Too big for me, but it is your setup. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.