Display manager doesn't start after newest Manjaro update

I always update whenever i get the notification from my package manager. I built my pc and put Manjaro onto it around November 2023.

I did that and the screen went back to being black but with a flashing " _" in the top left corner this time.

Manjaro gives the option to use all the simple GUI Tools, to archive the maximum user friendliness.

I know a lot Linux Terminal Warrior’s here don’t like it.
But the Tools are there… stay away from this commands, specially when you don’t want it or need it.

But use the terminal when you have it, find the sweetspott that you like.

1 Like

When you say boot into live environment , do you mean plug in the usb that i used to download Manjaro in the first place and boot from it by changing the boot order in BIOS? I tried doing that on my laptop but it said that there was an “Invalid signature” and it didn’t boot into manjaro. I am worried there will be some sort of issue if i put it into my pc and try to boot from it. The usb itself is called “MANJARO_KDE_2304”

I really don’t know how I would go about booting into live environment and restoring my snapshot with timeshift

Thats said, you can use the commands in TTY:

And install/remove the Kernels and maybe thats already enough… i can’t verify this commands, probably you need use update-grub after that? And maybe your system working already after it.

Yeah thats exactly what im talking about.

When you have a working timeshift snapshot, you can do it also the other way (and skip the TTY Commands) and boot with a working bootstick in life environment and start the timeshift UI from the taskbar and choose your snapshot there.

Restore the snapshot, follow the GUI steps… its pretty easy.

After your system is running again, you can install/remove the Kernel’s with the Manjaro Settings Manager, also a GUI.

Its total easy.

There is a saying: Many ways leading to Rome, which path do you choose is up to you.

Invalid signature is probably the secure boot option that is activated (enabled) in your Bios (also called UEFI-Bios) from your Laptop, so i guess your PC don’t have Secure Boot.

Secure Boot is a Microsoft Feature (or atleast have control above it) to control the boot access.
TPM is also a feature from Microsoft (or atleast have control above it) and wants to archive control above your PC.

Manjaro don’t support secure boot “Officially” (but it is possible to install it) and the only Linux Distro’s which officially support’s it are Ubuntu and Mint at least thats my Info that i have.

At the end of the day, wrong signature is not bad and shows your bootstick is not cursed :wink:

I recommend to disable this 3 features in your Bios, when you also want to use Linux on your Laptop:
Secure Boot (should be disabled already on your PC)
Fast boot (always recommend to deactivate it)

There is a danger with TPM disabling, when you have Microsoft Win11, the OS required TPM to boot. Only if you have it not disabled with a Rufus Bootstick Tool for Win11 installation to evade TPM support.

Microsoft Windows 10/11 also use Bitlocker with the help from TPM and use encryption keys (soulbound) your Partition (Files) to the TPM Modul, specially when you use OEM Laptop installation (90% chance that its activated).

Only disable it when you don’t have a encrypted bitlocker partition in use with Microft Windows.

Secure Boot:
Could be needed for your Laptop to boot Windows from it… but it should not required for Win10.

1 Like

To summarize, my issue is probably a Plymouth bug even though I’ve always updated my system.
And what I should do is

  1. boot into live environment on my pc using my (thankfully not cursed!) bootstick
  2. start the timeshift UI from the taskbar and choose a good snapshot there
  3. restore my snapshot, follow the GUI steps that are pretty easy
    4)Then when my system is running again, I should install a LTS kernel like 6.1 or 6.6 as @Joe_Ge said using the Manjaro Setting Manager

My Laptop is also Linux, but it is Linux Mint 21.2 the xfce version. It had Windows 10 then 11 on it originally but i wiped it from the drive when installing Linux Mint 21.1 xfce version.

I will go into BIOS and disable fast boot and TMP as i don’t have windows it should be fine? What is the benefit in disabling Secure boot?

You better get your system running again first and after that
you can try that.

TPM in general can also store encrypted keys for encrypted partitions. If you don’t have a encrypted partition, which supports TPM and is enabled with that feature… should be no problem then.

Fast boot is 100% safe to disable.

Well, you might saw the result already with your Manjaro Boot stick… it refused to Boot when the Bootfiles not certified.

I don’t have a good feeling to use a Microsoft Feature that is in control from this company and gives green light to access the bootfiles and allows your OS to boot or refuse it… doesn’t sound shady?

Atleast, if you still use Linux Mint on your Laptop… maybe it doesn’t matter. Its up to you.

Here just a little Hint:


You should look in the Announcements Stable Topic from time to time, this info in Known issue and solution is 4month old.

Good guide to disable plymouth:

But the bloody noob tutorial with no step cutting out you get only from me:

First command to use nano editor (when you dont have used Timeshift yet, you need to do this in TTY and log in and then…):

sudo nano /etc/default/grub

Look for that line and only remove the word splash :


With crtl+O and enter (you save the file) and exit with crtl+x

And after you done just this command:

sudo grub-mkconfig -o /boot/grub/grub.cfg

After a restart you see the result.

1 Like

Hello! Thank you so much for your advice and help so far!

I downloaded and installed linux66, then removed linux 65 and then used update-grub afterwards, all in tty2.
I checked in the grub menu and linux66 was first in the boot order. I tried booting a handful of times but i still have the black screen issue.

Do I proceed with removing Plymouth in the GRUB Commandline?

yeah, just follow my last reply… if you can’t find the word splash in the GRUB, you can use the linked guide to help.

1 Like

After clicking ‘e’ at the GRUB menu and scrolling all the way down
I found the line …" quiet splash udev.log_priority=3…"

do i just delete the “splash”, then crtl+o to save then esc to exit the GRUB menu, then

in tty2?
i didn’t do the sudo nano /etc/default/grub is that ok? Was i supposed to run those lines in tty instead of going into the grub menu?

I dont know, why you not just follow the few commands…

I can’t tell you now if E (EDIT) inside Grub Menue works now… maybe it does… maybe not and you run into additional problems.

When Grub changed, you should always use the last command… yeah

1 Like

I apologise but when i put in “sudo nano /ect/default/grub” in tty it said that the directory ‘/ect/default’ does not exist so i got a bit confused. But it did open GNU nano 7.2. I just don’t see any code at all.
I did not edit anything in GRUB edit menue

hmmm when i give the commands in terminal it works.

Maybe you need to enter the directory in TTY, try this in TTY first:

cd /etc/default

and try again

If /etc/ or /etc/default is missing then that would be a problem.

But I think it is just a typo.

ect should be etc

(as in ‘etcetera’)

1 Like

The question is, if he had make this typo only here in the Forum or in his console :wink:

Im gave him the right pathings :innocent:

1 Like

Thank you! It is working and I deleted “splash” from the specified “GRUB_CMDLINE_LINUX_DEFAULT=”
and the rest of the steps.

i rebooted and this time a bunch of code showed up instead of the log in screen (progress? :smiley: )
the last couple of lines say

[ OK ] Started Command Scheduler.
Starting Hold until boot process finished up. . .
Starting Terminate Plymouth Boot Screen . . .
[ OK ] Started CUPS Scheduler.

Well … sorta …

The ‘splash’ removal was supposed to stop plymouth from running.
But then

(plymouth is the fancy boot splash that mainly exists as bloat, but sometimes as a boot breaker … especially if one has missed kernel-mode-setting, or pacnews in general, but sometimes just because it feels like it)

If it were the same issue as previously experienced by users en-masse a bit ago, then you probably do have missing pacnews and/or unconfigured kms … but also you could probably continue avoiding that by doing your upgrades again while allowing downgrade (spotfix for previously mentioned plymouth fallout)

sudo pacman -Syuu

Of course my 100% honest opinion is that you should kill it with fire permanently.

You only see this lanes that told you that everything is okay… but you still dont have a desktop?

I just have a screen full of similar lines, nothing else is happening

If it continued then the final messages may be helpful.

If it stopped where you quoted then it might still be plymouth somehow.

When its again Plymouth i think he needs to finally kill it?

Im out of clue at this point…

I think he told me in this topic (above) his install was from 11/2023…

Would be strange if he had a pacnew file already from a relative fresh installation.