Display is randomly going all black

I tried looking for similar topics, never found any, moment I typed in the title for this thread 2 similar ones showed up (will link in a mo after uname output), at 1st I thought it was a power cut before the screen came back with my session as was, then I thought maybe the cables were loose, no go there either, I then tried checking if the kernel needed updating, also no go, did try the dmesg command mentioned in one of the other threads but no go, just said operation not permitted, is that one that should be under sudo?

Anyways here’s the output of uname:

uname -a
Linux zxuiji-manjaro-x64 5.11.0-1-MANJARO #1 SMP PREEMPT Mon Jan 11 00:50:28 UTC 2021 x86_64 GNU/Linux

Since the GPU isn’t shown there here’s what the System Info app showed me:

Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]

Got the whole PC off of ebay for £500, was working fine with previous kernels so I’m guessing this is specific to k11 until it stabilises further, don’t like dealing with mailing lists so I’ll let someone who does deal with manjaro’s kernel updates check if it’s a common issue or just something about my setup

Edit: Forgot to grab the links before hitting post, I’ll see if I can find it in my history
Edit 2: Found them:

Edit 3: Never mind, it was the cables after all, turned out when I lean on my desk the cables get pulled, will have to sort a better method of cable managed later

This is most likely hardware linked. I have seen this happening on computers after booting into Linux and Windoze as well, so most likely nothing you can fix on Linux level.