Display goes black, Kernel 5.9 & disconnecting HDMI

I am using Manjaro on a PC* whose HDMI is connected through a kvm switch. When Kernel 5.9 & KDE are up and running for a certain time and I switch to the other pc an back, the display remains black. Same thing happens if I connect the monitor directly to the pc and disconnect and then reconnect the HDMI cable, and sometimes the display goes black without removing HDMI or switching. I am not really sure what exactly the problem is, wheather the problem is Intel-specific, or the kernel in general. Kernel 5.8 however is very stable, no problems at all. Since it is really easy to have several Kernel in Manjaro I dont consider this much of a Problem (yet), so this is more of a fyi than a cry for help.
*ASUS N4000T, Intel Celeron N4000, Intel UHD600 Graphics, encrypted drive, KDE, Manjaro

If kernel 5.8 work well then use it. DO you have any specific requirement to use 5.9?

Read below.

5.8 is EOL. 5.4 LTS would be a better fit for this user.


1 Like

Thanks for correcting me Fabby. Sorry @Kessl, better to use 5.4. The idea is to keep a kernel which gives you full functionality, preferably LTS. Newer kernels only matter when you want to test them, when you have newer hardware not supported on older kernels, or when there are other improvements you need.

1 Like

But 5.8 > 5.4 :wink:
I just keep using 5.8 since I have no issues with it, everything works perfectly. I can live with a eol kernel.
This post was thought if soe. else experienced a black display while using 5.9 and did not know where it came from. It seems to be the kernel.

But 5.8 is EOL and 5.4 is LTS (Long Term Support)

If you continue using 5.8 beyond its end-of-life, you will open yourself up to security problems in the future or in the worst case: your currently running kernel will be deleted and you’ll end up with an unbootable system.

With rolling releases it’s always a good idea to have at least 2 kernels installed just in case and 3 is ideal.

So please: install 5.4 and check it out (I was on 5.8 too and 5.9 didn’t work neither so I upgraded to 5.4 too and will see what 5.10 brings and staying away from 5.9 for the foreseeable future)



Listen to Fabby @Kessl. It’s a bad idea to keep using an EOL kernel. As I said, newer kernels are only important if you specifically need them, so it doesn’t matter if 5.8 > 5.4. I personally use 5.4 on all my machines, except an old 32bit laptop with archlinux32, which is still using 4.19 due to compatibility issues.

1 Like

Hi there,
I noticed similar behavior on my HTPC with Manjaro XFCE on Intel Pentium J5005 with iGPU,
don’t know exactly which point release of the 5.9Kernel introduced this inconvenience, I was running just fine with the first iterations.

In my case switching on my AVR, which doubles as a switch, locks up everything with a black screen and i have to hard reset. Previous Kernels from 5.8 going back, don’t give me this issue.

At the moment I’m running on kernel 5.7, on older Kernels I have a stuttering problem I mildly contain switching of composition in XFCE before firing up Kodi. So using the 5.4LTS is not a solution in this use case scenario.

I tried out of curiosity the 5.10rc5, with the same result.
I installed the new Manjaro 20.2 on another partition, the XFCE version shows the same issue, I installed the Gnome variant and it works without problems, both use Kernel 5.9.

The issue seems not to be in the Kernel per se and I would love to continue to use the XFCE edition, but I lack the know-how to solve this problem further.

Maybe some of you young pros can kick this old dog in the right direction.

Thank in advance for any help.

Just to keep this a little up to date:
Problem remains in Kernel 5.10.7-3
I tested it on 2 different Machines both with Intel n4000 CPU and video-linux (default) driver.
I still can log in using ssh after the Display get black, sudo reboot does not reboot however.
Since the PC boots without problem and is useable as long as the display stays connected I dont consider this a huge Problem, however soe. using dual display setup might really be in trouble. You might want to consider installing 5.4 as stable fallback.

Hi Kessel,
good to know im not the only ony going crazy with this issue, wich now happens for me under Manjaro Gnome as well, but i may have found something!


by adding into “/etc/modprobe.d/snd_hda.conf” this line:
options snd_hda_codec_hdmi enable_silent_stream=N

i can now use all kernels up to the last RC, with dual setup, switch on and off screens and avreceiver, no lock up in the past 4 days.

i still have some weird behavior like screens not connecting until the avreceiver is not switched on again, but no lock up forcing me to hard reset.

maybe this fix can solve your problem too.


Please read this:

Hi Fabby,
thank you for your advice, REISUB was one of the first things I tried months ago, but it doesn’t work in this case, and yes SysRq key was properly unlocked and REISUB properly tested before recreating the lock-up condition.

Maybe Kessel could confirm this as well.

This seems (about 1 day testing, but things look good) to be the solution for this problem, thanks a lot grendeix.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.