Display Glitches when Shutting Down

I have been running Manjaro KDE Plasma on my desktop for a few weeks. Previously, I ran the Cinnamon edition but switched to see if the official versions were more stable. However, I have a couple of reoccurring video glitches. Also, I dual boot with Windows, using different hard drives. I have not had any similar problems using Windows, so I believe the issue is strictly with the Manjaro installation.

Often when I shutdown my system, a flash of pink, glitched lines briefly appears across my display. The system still shuts down though. Also, it tends to occur when I shutdown after waking the system up from sleep mode (not immediately after though, I can use the system for hours before shutting down). It happened more frequently when I ran the Cinnamon edition, sometimes when I was using light applications, such as Libreoffice and Okular. But the main way to reproduce the glitch is to put the system to sleep, wake it, then shutdown.

The other issue, which I believe to be related, is that sometimes, after selecting Manjaro at the GRUB boot menu, the login screen will not show up. A black screen is all that appears. Resetting seems to be the fix, but I felt like it might be related.

So far, I have tried switching kernels, from the latest 5.8, to the LTS, 5.4. Also, I have tried updating the graphics drivers, using both the Manjaro Settings Manager and the Manjaro Hardware Detection command. Both state that I have to correct drivers installed. Though I still believe the issue is with the drivers. One theory I have, based on reading various posts online, is that I will simply need to wait for more updates, to make the system more stable.
Any help would be appreciated. This is my first post, so kindly let me know if I can improve my forum etiquette.

Hardware info:

  Kernel: 5.4.60-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=0a49be96-a621-4f13-baab-956e0ece0ad1 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x serial: <filter> 
  UEFI: American Megatrends v: 1407 date: 04/02/2020 
  Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701013 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86279 
  Speed: 2621 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 3388 2: 2173 3: 2091 4: 2058 5: 2153 6: 4101 7: 2070 8: 2090 9: 3017 
  10: 1987 11: 1955 12: 4110 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] vendor: ASRock 
  driver: amdgpu v: kernel bus ID: 0a:00.0 chip ID: 1002:7340 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu 
  FAILED: ati unloaded: modesetting,radeon alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0") 
  s-diag: 777mm (30.6") 
  Monitor-1: DisplayPort-2 res: 2560x1440 hz: 60 dpi: 93 
  size: 699x393mm (27.5x15.5") diag: 802mm (31.6") 
  renderer: Radeon RX 5500 XT (NAVI14 DRM 3.35.0 5.4.60-2-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.6 direct render: Yes 
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 0a:00.1 chip ID: 1002:ab38 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0c:00.4 chip ID: 1022:1487 
  Device-3: Sunplus Innovation Lihappe8 Webcam L0485A2SP type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 5-2:2 chip ID: 1bcf:0b15 
  Sound Server: ALSA v: k5.4.60-2-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 2.29 TiB used: 678.63 GiB (29.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M81000G size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: S5Z42105 scheme: GPT 
  ID-2: /dev/sda vendor: Intel model: SSDSC2KW512G8 size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 002C scheme: GPT 
  ID-3: /dev/sdb vendor: Western Digital model: WD10EZEX-22MFCA0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: MBR 
  ID-1: / raw size: 931.22 GiB size: 915.60 GiB (98.32%) 
  used: 40.48 GiB (4.4%) fs: ext4 dev: /dev/nvme0n1p2 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 58.0 C mobo: N/A gpu: amdgpu temp: 48 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
  Processes: 300 Uptime: 17m Memory: 15.61 GiB used: 2.43 GiB (15.6%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1288 lib: 368 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

Hello and welcome!

These glitches could be a tearing problem.

Run this command and reboot.

echo -e "Section \"Device\"\nIdentifier \"AMD\"\nDriver \"amdgpu\"\nOptions \"TearFree\" \"True\"\nEndSection" | sudo tee /etc/X11/xorg.conf.d/20-amdgpu.conf


man amdgpu

for more information.


Hello, thank you for the quick reply.
I ran the command you posted, but unfortunately, after booting I am left with a black screen that reads:
[FAILED] Failed to start Simple Desktop Display Manager.

Thankfully I had Timeshift set up, so I will attempt to restore a previous snapshot.

That is strange…

There should be a file in


with this content:

Section "Device"
Identifier "AMD"
Driver "amdgpu"
Options "TearFree" "True"

Do you have any other config files there?

Yeah it’s what I get for blindly entering commands.
I do recall a similar ouput from the first command. Copied it down, but we’ll see after I atempt the restore.

Alrighty, I have successfully restored my system.
The directory you specified has two files, 00-keyboard.conf and 30-touchpad.conf. There is no such file called 20-amdgpu.conf.

A side note for anyone else reading this, USE TIMESHIFT! It will save your butt when you least expect it, and allow you to break things while learning!

At least, use another tty.

You could type CTRL + ALT + F1 for tty1, login and change the file with

sudo nano /etc/X11/xorg.conf.d/20-amdgpu.conf

Then reboot.
TTY7 is the graphical one: CTRL + ALT + F7

Could you explain what you think the problem is? It would be more helpful to identify the problem before I start trying things, given what happened earlier. I do think the problem has something to do with screen tearing, as I have also noticed some tearing in my web browsers.

From what I can tell, I do not have the specified amdgpu config file. Are you saying that I need to create the file manually?

Yes. By default it detects everything automatically. Unfortunately not everything works perfect. So the default settings have to be overwritten sometimes. The Option “TearFree” is by default “auto” and will be be forced by “true”.

I believe these glitches occur because of the system doesn’t wait long enough for the GPU to render the screen. If “Tearfree” is set to “true”, then it will wait as long as possible every time and the driver doesn’t decide itself, when to do it.

1 Like

Ah, interesting. I have been seeing these glitches too: Cinnamon on Intel video though. I have an AMD video box too, where I don’t see the glitches. I’ll have a look at setting/removing tearfree on both later.

1 Like

The weird looking screen upon shutdown is normal. At least it has been for me using a 5700XT.

The black screen is a little more concerning though. Next time, try switching to a TTY and dump the log to a file journalctl -b > dump.txt. The tail end of that log might help us discover the problem.

1 Like

Interesting, that the weird screen on shutdown is normal.
As for the black screen, it’s hard to repeat, but I will attempt to access a TTY if it occurs again. Some other research I found suggested that it might be due to the graphics drivers not loading properly upon startup, but the logs might provide more insight.
Thanks folks!

Should I post the entire log? Or just the last few lines?
Managed to record it.

I would say, post the last bit here. From where you chose to shutdown. Remember to use three backticks ` before and after the log to show it as preformatted text. You can then also hide the long text behind a summary with the settings wheel in the reply text box.

I have managed to implement the screen tearing fix, that was previously suggested. Currently, I have nothing else to report, but I expect I will need to use the system for awhile to know if it worked. Also, I have not been able to consistently replicate the problems.

I learned a few things from this, so thanks to everyone who responded!