Display before bootup

When I boot up there is no display. Literally nothing. The only time it shows display is when its fully loaded. Once the login screen is displayed its all fine, but nothing before it is displayed. This is an issue for me for many reasons; firstly, i’m trying to dual boot, and without seeing anything I can’t do anything. I can enter bios (I know that I’ve entered it because the screen doesn’t turn on at all, meaning its stuck in bios, sitting there, doing nothing). I’ve tried everything:

  • bootslash-manager
  • plymouth
  • editing /etc/default/grub

Output to cat /etc/default/grub

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=none
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment this option to enable os-prober execution in the grub-mkconfig command
GRUB_DISABLE_OS_PROBER=false

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki: https://wiki.archlinux.org/index.php/Fsck#Boot_time_checking
#GRUB_ROOT_FS_RO=true

If it happens even in BIOS, that’s likely a hardware issue. You should look for a BIOS firmware update first.


I cant update it if I can’t enter it

@caedenph

  1. This should work to enter the UEFI when logged in:
systemctl reboot --firmware-setup
  1. I would rather think that the keyboard is not fully initialized. Look for such options at the UEFI like “Fast Boot” and disable it.

I did this, the only thing that happened is it changed my desktop wallpaper to some color after it rebooted.

I think it is, normally when I boot up it just takes like 10 seconds, the keyboard has a white LED background, the background turns on and off a couple times. When I press F2 or F12 it doesnt continue into booting up, meaning something’s happened

You should be able to make the GRUB menu visible by editing /etc/default/grub to change:
GRUB_TIMEOUT_STYLE=none
to
GRUB_TIMEOUT_STYLE=menu

But I do not see how that would help to make BIOS visible before the GRUB menu

The only thing I recall about being unable to view BIOS settings is that when the BIOS was updated or reset, the default monitor output setting in BIOS would revert from the GPU back to the motherboard onboard graphics.

It was like that before, and I’ll give that a shot again.

For some reason I think it’s linked to this, I don’t know why or how to change it but I think it is - The monitor goes on sleep mode, because it doesnt detect any output, and my cpu doesnt have integrated graphics, do you know how I would be able to fix this?