Disk on which manjaro is installed won't show up in bios and i can't boot into manjaro

I tried to install manjaro on a new drive. I deleted everything from it and created the following partitions:
-512Mib fat32, mounting point: /boot/efi, flags: boot
-20480Mib linuxswap, mounting point: none, flags: none
-65536Mib ex4, mounting point: /, flags: none
-rest ex4, mounting point: /home, flags: none

There are no other drives with another os currently in the system. After installing no drive will show up in the bios as boot options. Im running in efi mode. Im new to Linux so i dont know what is wrong.

Hi Alexander, welcome to the forum :wave:

Have you disabled secureboot and use a GPT partition table?
Not sure if it this will help, my /boot/efi partition has the esp flag. I don’t recall setting that up at install.
The UEFI install is explained in detail here:

Ok, so now i used the erase disk option and it worked. I still dont know what in doing wrong with the manual parition. I used a GPT partition table. Also for /boot/efi there is only the boot flag and no esp flag. I think i read somewhere on the forums that they merged the two options together, but im not sure about that

I used gparted to partition my drive instead of the installer. This worked for me

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.