Disk image is only available for reading

Hello, I’m new to the Linux world and its pretty good so far. However I’m having this problem with my HDD where I can only read the content but cannot create or remove anything. Id like to use this disk as my download folder but cannot create a folder or nothing as I said before. If anyone has idea how to fix it I will be extremely grateful. Thank you regardless. Pd. Im not available to post any image or link but I tried to share some of my disk info.

Welcome to the forum! :slight_smile:

First things first. You’re talking of an entire disk, but HDDs and SSDs have partitions on them, and these partitions are formatted with some type of filesystem. It is the filesystem type that matters in this regard.

Now, I presume that ─ like most newbies ─ you are coming from the world of Microsoft Windows, and Windows uses a filesystem called NTFS. GNU/Linux supports reading from and writing to NTFS drives, but there are a few caveats… :arrow_down:

1. GNU/Linux is a UNIX-/POSIX-style operating system.

UNIX is an operating system architecture with a built-in security model based upon file ownership and permission masks. This ownership and these permissions are stored in the filesystem itself.

NTFS does not support this and will not store any POSIX information, which means that the file ownership and permissions have to be emulated in the kernel’s virtual filesystem layer whenever the NTFS filesystem is mounted into the UNIX directory hierarchy, and these emulated permissions apply to the whole filesystem ─ they cannot be set for individual files, and they cannot be modified while the filesystem is mounted.

The default mount options for NTFS ─ which include the emulated ownership and permissions ─ on a partition on a fixed drive are such that the root account becomes the virtual owner of the files, and that only the root account has write access to the device. If the device is auto-mounted “on the fly” ─ usually under /run somewhere ─ via the udisks2 subsystem of systemd, then these are the defaults that apply.

If you want to circumvent this, then you should bypass this method of auto-mounting by adding a line for the NTFS filesystem in /etc/fstab, in which you specify the correct mount options, including who is to be the virtual owner of the files and what the permissions must be.

There are threads here at the forum with all the correct information, and you can also find information about this at the links below… :arrow_down:

2. Disable the Windows Fast Boot feature.

Windows Fast Boot does not properly shut down the Windows filesystems. If you then boot into GNU/Linux afterwards, then the Linux kernel will detect this and will conclude that the Windows filesystems may have been corrupted, and it will subsequently mount these filesystems in read-only mode in order to prevent further filesystem corruption.

3. GNU/Linux must in its entirety be installed on a Linux-native filesystem with POSIX file ownership and permissions.

You cannot install any part of the UNIX file hierarchy of a GNU/Linux system on NTFS, for reasons mentioned in #1 above. Therefore, your root filesystem (/) and ─ if separate ─ /home must reside on a POSIX-compatible filesystem such as ext4 (which is the default in Manjaro), reiserfs, btrfs, xfs, jfs, f2fs (SSD only), yaffs2 (SSD only), or a similar filesystem.

What you can do ─ as per the advice in #1 above ─ is create directories (“folders”) inside your $HOME and set those up as the mountpoint for the NTFS partitions you wish to mount.


Let’s begin with information about your partitioning.
lsblk -f

Which partition among those listed in the result do you try to write on?

1 Like