Discord is not automatically updated

I can’t get into Discord. I have Discord verison 0.0.19. The version on Arch Linux is 0.0.20-1. But when I do “yay”, Discord is not updated. Why?

PS! I think I installed Discord with yay many years ago. But I can’t remember.


Manjaro does not use Arch repositories.


Even more info

1 Like

Manjaro maintainers, what’s wrong with you? You can’t update Discord for 5 days when it appeared in the Arch repository day after day.
Manjaro not supported now?
The distribution is already losing popularity, and with this approach, the road to the bottom will become very fast.

The vast majority of software can be used with a pending update.
Just saying…


I agree with you that Discord acted ugly, but at the same time, other distributions are devoid of our problems.

Use the flatpak version. Problem solved.

1 Like

It has been on the Unstable branch since it is updated on Arch. On Testing branch since yesterday I think, and will probably trickle down in Stable later. What’s wrong with user not understanding how it works and all the alternatives of using the repo package, which will continue to have this issue of not being updated instantly. It’s not like Discord is a critical package that requires fast tracking and packaging from Manjaro team and that there is no alternative as said (I guess they have other things to do, more important).

Maybe if asked in a proper way, and the community shows interrest and maybe a trusted member can do the work, it could be possible to have Manjaro own packaging and fast tracking.

1 Like

The problem is not solved.
You can install discord on Linux in many ways, but this is absolutely no reason to have unupdated and, moreover, non-working packages in the repository.

1 Like

If you want packages a a higher cadence - switch branch and be done with it

sudo pacman-mirrors -aS unstable && sudo pacman -Syyu

This will bring you - mostly - on par with Arch


How unstable is ‘unstable’?

Will I have random shutdowns and freezes everyday, or is it just a unresponding program once in a while?

I try to avoid flatpack as much as I can. But I need discord for work.

I have been using unstable branch for more than 5 years - it is as stable as you make it.

This should be understood as - stay as close to upstream as possible - don’t rely on widgets and whatnots - as they tend may break without warning - don’t apply fancy themes - they tend to be unmaintained after some time and they may break your system as well.

I don’t have any random shutdowns or freezes - I don’t know what gave you that idea?

Remember this:
The vast majority of Manjaro repo is coming direclty from Arch stable repo.


Thank you! I will give it a try! :slight_smile:

I’m more the default-settings guy and have no fancy themes, so I guess I will be fine with unstable :slight_smile:

1 Like

I agree on that one. Personally, i have been in favor of ditching it from the repositories for a long time.
Though, since there is a way to disable that update check, shouldn’t we have that by default in the package?


As it is a package imported from Arch, and as far as I know nobody wants to take responsibility (and all the involvement that it means) to package it for Manjaro, I guess this change should be made upstream?

Maybe we could simply make a tutorial in #contributions with this tip, and all other methods of installing Discord, so users stop ignoring the issue and its many solutions, and may stop blaming Manjaro for not packaging and fast tracking this package.

You may yes, but you may at some point have an issue that you’ll most likely be on your own to debug and fix. Unstable branch is not dangerous, but it happens, as the packages are tested from Arch on this branch, that a problematic situation occurs on Manjaro Unstable. It is not to scare you, it is a possibility, and as there are MANY solution to install Discord and be done with the issue, I would recommend you go one of these ways instead of using Unstable branch, which will not solve the issue that Arch takes days every time to update Discord.

1 Like

Hi, i know there’s issues every time discord updates, but it’s been almost two weeks and the AUR hasn’t been updated and the flatpak for some reason won’t let attach any image :confused:

Any suggestion? i mean, for now i’m using also the web option, but it would be awesome to continue using the app.

Thank you.

PS: i’m linux beginner and not a programmer

Here is the simplest option IMO. Download the tar file it gives you when you open discord and select the Linux option in the drop down. Then extract the folder from the tar file via either terminal with
tar -xf filename.tar.gz
or by opening the tar file with archive manager, and dragging out the folder in which ever directory you want in your file manager.
From there you can nav into the discord folder and run the executable :slight_smile:
(if you don’t want to nav to this folder every time you can create a desktop link by right clicking the executable → Send To → Desktop (Create Link)


Shortly, you can just change the script with Discord version in the terminal (I use it for the app from official repository):

  1. sudo nano /opt/discord/resources/build_info.json (RMB to paste something into the terminal)
sudo nano spoiler

Be careful by running something (scripts and apps) from the terminal with sudo command as it mostly not needed and can break some stuff.
In this case, nano is a simple text editor for the terminal.

  1. Change version number to needed
  2. Ctrl+S to save changes
  3. Start the Discord

More detailed explanation at this video I used.


To add what I use when Discord is out of date I just install the current Arch version, if the Manjaro repos catch up then it will be updated normally when they do.

sudo pacman -U https://archlinux.org/packages/community/x86_64/discord/download/

Seeing as Discord isn’t packaged separately for Manjaro and we use the Arch package, is there anything that needs to be done testing wise to fast track it? I’m not going to claim to have the competence or reliability to be a proper package maintainer but if there is just some simple testing that needs to be done to get the Discord package moving forwards for people I would be interested.