Discard on the fstab...SystemD fstrim.timer

Hello,
During installation, the “discard” option is added to the fstab file.
However, this option is deprecated, especially by RedHat, because it “trim” continues the file system, adding workload to it, this is the opposite of the desired effect.
SystemD manages the trim with the fstrim.timer.
Why do not Manjaro use this service instead of the discard option?
Regards,

A Monkey In Winter

What ISO install media did you use? On my installs i never had that on a rotational HDD, and also nothing like that on my SSD installs.
HDD install fstab:
UUID=0281c7b8-1edc-4547-9653-c8328a046ec7 / ext4 defaults,noatime 0 1
SSD install fstab:
UUID=92853c68-c459-45b9-b9fd-8f0676e1f678 / ext4 rw,relatime,data=ordered 0 1

Hello,

An Tux’N’Vape .iso
https://www.tuxnvape.fr/telechargements/

Its a respin of Manjaro, just a respin.
Installer is the same of Hakoila.

Discard option is on the fstab file, for the ssd only, in my case.
If I look on the forum, I find other topics.


Regards,

A Monkey In Winter

Might be something that got slipped in the newer ISO and i didn’t noticed it. I have only the good ones :wink:
Since all this is already known and fixed by manjaro team, maybe better wait for a newer iso or use the previous ones that do not have this “bug”.

I think it would be interesting to know if other users had this option to add. :slight_smile:
However, I tried, there is little time, .iso “official” and I had the same problem.

Regards,

A Monkey In Winter.

It only takes a couple of minutes to correct if you know what is required. Yes it’s a Calamares bug, maybe it only happens in some flavours of Manjaro. For someone who’s up on the details, its no big deal. For newbies, messing with fstab could lead to real problems. Hopefully it’s corrected soon.

1 Like

Hello tbg
“It only takes a couple of minutes to correct if you know what is required”
Its true :slight_smile: Delete “discard” from the /etc/fstab file
Enable fstrim.timer (sudo systemctl enable fstrime.timer),
Start fstrim.timer (sudo systemctl start fstrim.timer),
Find out if the order has been correctly answered (sudo systemctl status fstrim.timer).
It is true that the fstab file is to handle with extreme precaution.
I use an Mate flavour.
Regards,
A Monkey In Winter.

2 Likes

BTW, just FYI. You don’t have to retype what someone already wrote. Simply highlight via left click/drag the text you want copied, and hit the “quote” message that pops up. Easy, peasy.

Thanks for listing the info on resetting fstrim for those that are unsure.

Thank you for the kindness to forgive my debut on this forum, and therefore on its use :wink:

2 Likes

Well then, welcome to the forum as well.

quicker still as it does both commands in one hit:

systemctl enable --now fstrim.timer

2 Likes

Just to report that this issue is still open in the latest ISO.

I’m trying to remount my partitions to clear the discard setting but it seems that it cannot be done without rebooting…

found the answer:

sudo mount -o remount,nodiscard /partition

1 Like

Forum kindly sponsored by