Disabling the continuing beeping from Bios

.There a beep is coming from Bios …when I was using Windows I was just switch off the sound but now even switch off the sound …the continues beeping is still there. I donot need the sound any …i want to switch off all the sounds


I cannot understand

run this command:

echo "blacklist pcspkr" | sudo tee /etc/modprobe.d/nobeep.conf

then reboot

The command not found

what do you mean not found… theres nothing to be found, just copy the command into terminal and click enter, then reboot

There’s three commands: echo, sudo, and tee. All of them should be available by default.

I did…i caopy paste the command and i reboot but again it is continuing beebing

whats the output from:
cat /etc/modprobe.d/nobeep.conf

The result is

blacklist pcspkr

so did it worked? is there no beep sound anymore?

The beep is still continuing

It is coming from Bios

so why did you mark it as solved? … and with beep sound you mean when you start up your pc, there is one beep sound?

No it is 5 beeps …the labtop is dell…

I just want to stop the sound for now and i will fix thw hardware later .

Sorry I marked solved by mistake

so unmark it, so that others may help… there should be a setting in bios to disable the sounds, did you checked?

1 Like

I keep wondering if nobody here is interested in the fact that these could also be BIOS warning messages that indicate a serious error. The main thing is to rest first… :grinning:


It is Bios warning …i think the clock battery. CMOS? I just want to switch off the sound …i checked Bios notinf rherw

there should be a Quiet Boot option in your bios settings…

Unfortunately therw is no quite boot option

That can not be true. Are you a supporter or an arsonist?