Disabling multicasts for Apple products and other wireless stuff

I’d like to have full control over when my computer says it can accept the myriad protocols currently being multicasted on the network.

  • After a tcpdump, I’m trying to work out where the multicasts for things like AirPlay, airport, REDlink, printers, scanners etc were coming from.
  • Couldn’t see that avahi was running. Eg. ps -ef | grep avahi ??? Nope. Nothing.
  • Renamed gvfsd-dnssd and gvfsd-network in /usr/lib/ folder, and killed the processes pkill -9 {gvfsd-dnssd,gvfsd-network} , and restarted the NetworkManager.
  • Concluded the multicasts did not come from those processes.
  • Opened the “nm-connection-editor” (Advanced Network Configuration in the Whisker menu) and crudely just disabled IPv6 completely, hit Save and closed the window, restarted the NetworkManager with sudo systemctl restart NetworkManager but alas the IPv6 multicasts are still being sent out.

What is the proper way, to ideally “disable” the multicasts without completely uninstalling avahi?

Is the avahi-daemon running?

sudo systemctl status avahi-daemon.service

Have a look here:

cat /etc/avahi/avahi-daemon.conf
man avahi-daemon.conf

If it is not running, then avahi is not the source.

1 Like

Are you sure theses multicast packages are from this system and not from other devices in your network?

1 Like

All that can be said here is try (if you can) connecting and disconnecting other devices, on the network and see what happens in tcpdump, yes.


Thanks both of you. Getting the quality noob feels, today.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.