"Disabling IRQ #7" on boot and shutdown?

Hey everyone,

Every time I boot or shutdown my PC it gives says “Diabling IRQ #7”. I can’t find anything about it online. The reason I think it’s an issue, is because it takes unusually long to shutdown.
Any ideas?

OS: Manjaro Linux x86_64
Kernel: 5.15.12-1-MANJARO
Uptime: 16 mins
Packages: 1108 (pacman)
Shell: bash 5.1.12
DE: Plasma 5.23.4
WM: KWin
Theme: Breath Light [Plasma], Breeze [GTK2/3]
Icons: [Plasma], candy-icons [GTK2/3]
Terminal: yakuake
CPU: AMD Ryzen 5 4600G with Radeon Graphics (12) @ 3.700GHz
GPU: NVIDIA GeForce GTX 1650
GPU: AMD ATI 0d:00.0 Renoir
Memory: 2347MiB / 15431MiB

Really? It usually indicates some sort of hardware compatibility/configuration/etc issue.

Please see this:

And this for some examples to investigate the particular issue further (lspci, dmesg, etc)

From what I can gather, there’s not really anything I can do about it. But it also seems that it wouldn’t have anything to do with my slow shutdown time. Or what do you think?

EDIT: found a lot of errors with “sudo journalctl -p 3 -xb”

Here is the output:

kernel: ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.GPP0.VGA], AE_ALREADY_EXISTS (20210730/dswload2-326)
kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20210730/psobject-220)
kernel: ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.GPP0.HDAU], AE_ALREADY_EXISTS (20210730/dswload2-326)
Jkernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20210730/psobject-220)
kernel: irq 7: nobody cared (try booting with the "irqpoll" option)
kernel: handlers:
kernel: [<00000000467ba416>] amd_gpio_irq_handler [pinctrl_amd]
kernel: Disabling IRQ #7
systemd-coredump[712]: Process 611 (Xorg) of user 0 dumped core.
░░ Subject: Process 611 (Xorg) dumped core
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ Documentation: man:core(5)
░░ Process 611 (Xorg) crashed and dumped core.
░░ This usually indicates a programming error in the crashing program and
░░ should be reported to its vendor as a bug.
Jan 15 21:53:17 amp9k-pc sddm[571]: Failed to read display number from pipe
Jan 15 21:53:22 amp9k-pc systemd[767]: Failed to start Update XDG user dir configuration.
░░ Subject: A start job for unit UNIT has failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ A start job for unit UNIT has finished with a failure.
░░ The job identifier is 27 and the job result is failed.
Jan 15 21:53:31 amp9k-pc bluetoothd[641]: Failed to set mode: Blocked through rfkill (0x12)
Jan 15 22:42:59 amp9k-pc knshandler[4787]: kf.newstuff.core: Could not determine type of archive file ' "/tmp/ZvyqzS-Sweet-Mars.colors" '

Please return system info as above, along with

mhwd -l -d
1 Like

can you provide

inxi -Fza
1 Like

You could try doing what the kernel message suggests
add that keyword to the end of the line that starts with:

You can do that temporarily
by pressing ESC to show the Grub menu, in case it is not shown
and then e as it says in the description on that page that is shown

or by editing /etc/default/grub
and then regenerating the configuration (run: update-grub)
but that is then permanent unless you remove it again
in case it doesn’t improve your situation.

The first variant is perhaps more tedious, but safer because it is not permanent - in case that modification will have unintended effects or even prevent boot … just reboot and it’s no longer there.

1 Like