Disable transparency on windows and application menu


I recently did update with sudo pacman -Syu --disable-download-timeout because my audio stopped working for some reason. After the update all windows except the focused one became transparent. Application menu also became transparent. Any way to disable this? I have Kvantum manager installed and I tried to tick “Disable composite effects” option but It wont work.

I had the same problem a couple days ago, and I found a half solution if you’re interested.

If you’re also running bspwm, then sxhkd has a keybind (super + ctrl + space) that kills the picom process and runs it again. If you toggle this enough times it will give you the proper shadows. If you aren’t interested in that you could also just kill the picom process and it will make everything opaque.

If you aren’t running bpswm, then the actual commands in that keybind are {pkill picom \ picom -b } I’ve made it work from command line by running pkill picom and then picom -b in that order until you get the desired effect.

If someone has an actual solution, I’d like to see it as well, this should be a stop gap for you until then.

This post might help:

@gregaras any chance that this helps you as well?
What DE or WM are you using?

1 Like

I ran pkill picom without any message and picom -b gave me:
[09/12/2020 22:09:51.543 session_init FATAL ERROR ] Another composite manager is already running

I’m not able to find picom file in .config.

I’m not sure, I think they are LXQt and Openbox.

Oke, managed to disable it. Went to Preferences > LXQt settings > Session Settings and in Basic Settings, LXQt modules section unchecked Compton. Had to logout, login and it worked.

Edit: Found there was configuration file picom.conf in /etc/xdg in which I tried to edit opacity. It let me turn off transparency with Compton enabled.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.