Disable the search in Desktop folder when using GTk4 Desktop Icons NG


Is the first time I have used Manjaro and I have found a problem that is bothering me a lot. I comes from Fedora with Gnome too but this problem was not happening, so I suppose that there is a way to disable this behaviour.

I have activated the “GTk4 Desktop Icons NG” extension to show my desktop icons, but now every time I change to another window instead to focus in that window, it seems to be focusing in the desktop and then when I start typing it opens a search box to find files in the desktop (I can’t attach a screenshot for now).

I have searched in all the dconf and the extension options, and in several posts in Internet but I was not able to find the way to disable that search box. Even I have disabled the indexer and nothing has changed (this also was because the resources usage).

Someone knows anything about this problem and how to solve it?.


There’s a possibly related bug, see here (original package).
The extension itself is not handling things properly and ends up ‘stealing focus’ (or clashes w/ some other extension).
You can try reinstalling the package
sudo pacman -S gnome-shell-extension-gtk4-desktop-icons-ng
(deactivate → reinstall → activate)
Also, try running a Live USB and activate the extension there, see if it’s any different.
No other ideas.

1 Like

Thanks, I’ll try to continue searching if I can find a solution. Is strange because I come from Fedora with the same Gnome version and this was not happening. Even more, I was using Fedora for a long time starting at Fedora 32 and upgrading the SO (dirty upgrade), and I have never got this problem.

Best regards.