Disable tap-click and tap-drag on XFCE libinput Logitech K400

I am using a Logitech K400 wireless keyboard with a built-in trackpad.

I can’t disable tap-to-click for the trackpad in the XFCE mouse configuration.

Sometimes I accidentally drag files around or perform unintentional clicks on webpages, it’s driving me crazy.

There’s bound to be some config file I can edit to disable all tap actions on the trackpad. Anyone know where?

Thanks.

Since XFCE then not wayland so you can use the Xorg configuration file.
ex:
/etc/X11/xorg.conf.d/99-touchpad.conf

Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "ClickMethod" "clickfinger"
    Option "DisableWhileTyping" "off"
    Option "Tapping" "off"
    Option "TappingDrag" "off"
    Option "TappingDragLock" "off"
EndSection

(obviously augment or omit any options you want)

PS.
Here you can see all about the options;
https://man.archlinux.org/man/libinput.4#CONFIGURATION_DETAILS

1 Like