Disable supergfxd from grub

I have my Manjaro installed on external USB drive which I use on Asus and HP laptos. Asus has Nvidia, and HP does not. I need to disable the supergfxd for the HP configuration as it floods the logs with the messages WARN: get_runtime_status: Could not find dGPU.
I created a section in boot menu in 40_customs and now I need to disable supegfxd for HP only. Could anyone show an example how to do this?