Disable Slack opening in fullscreen i3


slack-desktop 4.23.0-1 always open in fullscreen on i3.

How can I disable this behavior? I’ve tried setting this the i3 config file:
for_window [class="Slack"] fullscreen disable

Not sure that works that way, because to display a window in fullscreen mode or to go out of fullscreen mode again, you have to press $mod+f.

There is also a global fullscreen mode in i3 in which the client will span all available outputs (the command is fullscreen toggle global). So not sure there is a fullscreen disable

Better go with:

for_window [class="Slack"] floating enable

or depending if you want border or not you can add to it border normal or border pixel 1 if you want a 1 pixel border … and then use the $mod+f to exit full screen and resize it as you prefer it, it should keep the size you set next time …

Probably a bit late… but I experienced the same thing.

It seems to be as simple as this: the slack application is making itself full screen at start up!
Somehow I had clicked on “View/Toggle Full Screen” (or gotten Ctrl+Windows+F into the application). And that toggle sticks. So slack full-screens itself at start up.

Untoggle “View/Toggle Full Screen” — obviously there isn’t a check mark or anything, since that would be useful and informative — and restart slack.