Disable node suspension in WirePlumber


I upgraded my system today and noticed that wireplumber replaces pipewire-media-session now. After restarting my PC following the update, I found that the sound nodes were suspending and causing “popping” sounds when playing sound. I had a similar issue with pipewire-media-session but was able to fix it by editing /etc/pipewire/media-session/media-session.conf and commenting out:

suspend-node # suspend inactive nodes

I can’t seem to find a similar option in the wireplumber configuration file. Is there something that should be added to the default configuration to add this feature or does this not exist in wireplumber yet?


1 Like

I only found this about configuring wireplumber:

Maybe wireplumber use the same configuration files from pipewire-media-session, don`t know, I will do some tests.
I didn’t made any changes in my personal configs in /home/sergio/.config/pipewire/media-session.d and is working as expected with wireplumber.

But, you can disable suspend-node in the file “media-session.conf” on the directory /home/“user”/.config/pipewire/media-session.d ??

My answer to this is so confuse and I think that somebody could explain more clearly.

I think I found the soultion:
edit /usr/share/wireplumber/main.lua.d/90-enable-all.lua file and comment “load_script(“suspend-node.lua”)” with –

1 Like

I am looking for a way of when I connect my bluetooth headphones, wireplumber switch automatically to it’s output.
Wireplumber does not have any user configuration.

I was researching for that as well and found this.

To tell wireplumber to select a BT headphone by default:
pactl load-module module-switch-on-connect

1 Like

I copied /usr/share/pipewire/pipewire-pulse.conf to /home/sergio/.config/pipewire and remove the “#” from the line

#{ path = “pactl” args = “load-module module-switch-on-connect” }

1 Like