Disable Manjaro terminal autocomplete

I’m new to manjaro, I realized that in the terminal there is autocomplete activated, then I installed tilix but there is also autocomplete there. I would like to know if there is a way to disable it, thanks.

I’m not familar with tilix, but autocomplete is a function of the shell that is run inside the terminal. The default shell is bash. The package is bash-completion. It is sourced at the end of the file /etc/bash.bashrc. Comment the line or uninstall the package as you see fit.

Bash has been the default but these days - depending on your chosen environment - the default shell could be zsh.

Editions which uses zsh as default shell is

  • Gnome
  • Openbox
  • LXDE
  • LXQt

Had no idea. Good to know. Thanks. :slight_smile:

I just figured bash was the default and other shells were user post-install options. That sort of info isn’t documented at distrowatch. I did do a google search, "site:manjaro.org zsh -forum -discover -list, and it doesn’t seem to be documented at Manjaro either.

I see there is a zsh-completion in the repo. It seems to have similar startup files.

If you installed a recent version of GNOME, the default shell is zsh. If that’s the case, your prompt will look something like this:


instead of this:


If that’s the case, then you’re possibly referring to auto-suggestions provided by zsh-autosuggestions. You can just uninstall that if you don’t want it.

Suggestions appear as you type, completions do not appear unless you press Tab to see them.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.