Disable keyring prompt Manjaro cinnamon

Hi all,

Running Manjaro Cinnamon and whenever I login I’m asked for a keyring password. In Linux Mint cinnamon I was able to go to the password manager and change this but I can’t find the corresponding place in Manjaro Cinnamon. My computer logs in automatically when I boot and I read perhaps that’s the issue? I’m happy to go back to logging in with password if it means I don’t get this prompt when I boot up. Some step by step instructions would be very helpful. I’ve looked but can’t find the answer to my specific circumstances.

Thanks,

I have not tried it, but seahorse seems to be in the official repository. But perhaps it’s not good security practice? :thinking:

As far as I know I don’t use the keyring for anything though?

This issue usually surface when one is using or has been using login then switch to auto login.

The system always uses a default keyring - whether you know it or not - and when changing the login procedure your keyring is no longer unlocked on login and that is why you are asked for access to the keyring.

The behavior can be modified by using seahorse and either use an empty password for the default keyring or sync it with your login password.

Forgive my question, I’m a bit of a noob here but I’ve dl’ed seahorse. I have some passwords listed, for evolution, firefox etc. But I’m not sure how to change the autologin settings and get it to sync with the keyring. Any ideas here? I feel like after having installed cinnamon over xfce that some of the Cinnamon functionality I was used to in Mint isn’t here. Not a bad thing bc I know I can install stuff I need, but just wondering if I"m missing some configuration apps other than seahorse?

Not that I know of …

All good. So how do I change my settings to require a password at boot? Or is it difficult to do that once installed?

I do not use autologin, but should be in Cinnamon settings, Login Window, Users tab. Otherwise the prompt should only be asked for once per session as far as I know.