Disable HDMI audio from DP.

Inxi of Patient.

My Monitor is connected via Displayport from my AMD RX570.
Since the monitor has speakers and KDE is kind of stupid. It absolutely refuses to stay using the onboard sound after suspend.
I've tried turning off the selection in KDE but... well... it's KDE so obviously it won't obey.

How can I disable the DP audio?
I've tried Blacklisting the snd_hda_intel but then I have no sound.
I'm really not sure how to go about this...

cat /proc/asound/modules

0 snd_hda_intel
1 snd_hda_intel

lsmod | grep hdmi

snd_hda_codec_hdmi     69632  1
snd_hda_codec         159744  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          102400  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_pcm               139264  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd                   110592  20 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm

hwinfo --sound

34: PCI 800.1: 0403 Audio device                                
  [Created at pci.386]
  Unique ID: 7Wns.Pp7gj69S_14
  Parent ID: w+J7.0TU4LKoL980
  SysFS ID: /devices/pci0000:00/0000:00:03.1/0000:08:00.1
  SysFS BusID: 0000:08:00.1
  Hardware Class: sound
  Model: "ATI Audio device"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0xaaf0 
  SubVendor: pci 0x1682 "XFX Pine Group Inc."
  SubDevice: pci 0xaaf0 
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xfcf60000-0xfcf63fff (rw,non-prefetchable)
  IRQ: 82 (238 events)
  Module Alias: "pci:v00001002d0000AAF0sv00001682sd0000AAF0bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #6 (PCI bridge)

35: PCI a00.3: 0403 Audio device
  [Created at pci.386]
  Unique ID: Dt9q.ul4ScaGyp28
  Parent ID: JZZT.XtQqpuv2hW0
  SysFS ID: /devices/pci0000:00/0000:00:08.1/0000:0a:00.3
  SysFS BusID: 0000:0a:00.3
  Hardware Class: sound
  Model: "AMD Audio device"
  Vendor: pci 0x1022 "AMD"
  Device: pci 0x1457 
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x86c7 
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xfce00000-0xfce07fff (rw,non-prefetchable)
  IRQ: 80 (125791 events)
  Module Alias: "pci:v00001022d00001457sv00001043sd000086C7bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #28 (PCI bridge)

Thank you!

are you able to disable it from alsamixer?

I can select it but I can't disable it in Alsa. Unless I'm missing it.

you should be able to press "M" to mute it.

maybe i misunderstood the issue. after reading the OP again, you want to disable any audio output from the RX570 so the onboard audio is used instead?

before suspend, audio comes from the onboard audio, after waking it defaults to the RX570 as the audio device?

no surprise there. do you have pavucontrol installed? you can disable audio by device from there

Correct.
I have to manually switch it back to the onboard after suspend.
It does it even if I reboot. I have to manually switch back to onboard.

I've muted/turned off the 570s audio in everything I could think of but it just won't do it. :smirk:

I'll check on pavu

I do not. Install it?

1 Like

yes, it should be able to do what you need and remain persistent.

3 Likes

Ok, I'll install it here in a minute.

I'm installing another program (unrelated) and apparently I have to build the entire qt4 library.
/sigh

1 Like

Worked like a charm. :hugs:

Stupid pulse/kde! :wink:

Thank you @dglt!

1 Like

yw, glad it worked out.

i could go off on a rant about pulse issues that only seem to happen with kde, but i wont do that. i could talk about kde and it's disregard for keeping settings, but i wont do that either. :smirk:

1 Like

It definitely has some serious issues with obeying settings.

It almost seems random too. It's really super finicky.
/sigh

eyes openbox again

1 Like

but is it fault of KDE ?

I know Pulseaudio can be squirmy little critter at times even for me on XFCE

There is module-device-manager that KDE specifically requires and other DEs don't
if that was absent may explain KDE settings not getting to pulseaudio

but pavucontrol can usually fix it on any DE anyway

2 Likes

I think so. But I blame most things on KDE. :wink:

I checked and I do have module-device-manager.

So I have no idea what it's problem is. So I go back to "It's KDE's fault." :grin:

Welp, when I came back from suspend this morning (Yes, me and my computer) it did it again.
Now Pavu doesn't give me the option to turn off the RX570s audio.

/sigh

It worked in my tests. I don't know why it did it again.

when i was using kde (and only on kde, never happened on any other DE/WM), the only way i was able to get pulseaudio to stop being a pain in the arse was to restart pulseaudio in user mode (like it's suppose to be). without this, any changes to settings would revert themselves on every pause/play or switching to the next track which was ridiculous.

after running this, everything works as it should so i set this command to be run when kde starts.
systemctl --user restart pulseaudio

without running that on boot, pulseaudio just seems to do whatever it wants. restarting pulse with pulseaudio -kjust results in the same undesirable behavior.

1 Like

Thank you.
What a giant pain in the a$$.

I setup the autostart with the command.

I'm seriously starting to wonder why I'm still using KDE. Love some of the functions and options it has but the trade off is this kind of nonsense.
/sigh

So tell me...

You use awesome. what's your thoughts on i3 or i3-gaps?
awesome does tiling and floating, correct? Whereas i3 is purely tiling?
Not that afraid of LUA but the amount of customization sort of spooks me.

1 Like

i3 is definitely more popular and i gave it shot before trying awesome but i felt like i needed to grow an extra set of fingers to use it, i also prefer the way awesome handles keybinds which i find more fluid than the i3 ones. this of course could be easily changed by setting each keybind in i3 the way i want. and rather than having keybinds all displayed as a conky so you can remember them, with awesome you just press super+s and it shows all currently configured keybinds and goes away after.

i dont remember if i3 is exclusively tiling but again i found awesome to handle this better and yes, you can have windows open as tiled or floating.

if your familiar with LUA, the possibilities are endless. even if your not, the configuration that the manjaro community iso uses is a far cry from a vanilla awesome-wm setup and anyone at any level could boot and use this setup as is with ease. for someone that likes to tinker with things and make them your own as it seems you do, it's a great WM.

in other words, i dont miss kde. :sunglasses:

1 Like

Thank you for the explanation. :grin:

I'm starting to regret using KDE to be honest. Which kind of blows because I just discovered Latte dock, which really is fantastic.
But man, some of the issues I'm having with KDE are starting to wear on me.
So much so i was considering moving to Mate which I really like but wow, so not customizable.

I did play with Awesome a tiny bit in VM before getting the new mobo but not enough to get a feel for it.

Think I better get Vbox installed and spin up the VM again.
You know, provided KDE doesn't burst into flames or something. :fire:

1 Like

Wow, it simply will not turn off the DP audio coming back from suspend and about 50% of the time rebooting.
None of the setting will stick.
Maybe sudo pavu or some config I can set? I'll have to look.
I really don't know wtf KDEs issue is with keeping configs set.
Making me crazy(er).

1 Like

post your xrandr --prop output, i have an idea :bulb::thinking:

1 Like

Forum kindly sponsored by Bytemark