Disable hardware on Rpi4


My configuration is Raspberry 4 with SaundBlaster PLay 3, RTL-SDR dongle connected with a 20 cm USB extender cable and the official Rpi touchscreen running on 64bit Manjaro linux. Additional wireless USB mouse and keyboardThe device is powered by a Meanwell adapter. All this is inside my car.

This makes the Rpi noisy - some high pitch noise appears if the screen brightness is high. If I remove the RTL-SDR or disconnect the audio cable, the noise disappears.

My question is - is there a way to disable parts of the hardware that I do not use - for example the LAN port and the two HDMI ports?

That sounds like RFI

1 Like

The noise appeared after I’ve added the RTL-SDR dongle. It was fine with all other stuff connected. Some say it may be because of the RTL-SDR drawing too much power (0.7W). That is why I’m looking for a way to cut off hardware I do not use. Remember the noise gets louder if I increase the brightness of the display.

Merlock, do you think if the noise is because of RFI it will get lower if I use longer USB extender to move the antenna further away from the Rpi?

I’ve also read somewhere that the USB extender cable should be stripped to have only the two data wires when using it to connect an antenna. Is that true?

I have a RTL-SDR I use as an OP25 trunking radio scanner and it is on an extension and I have no issue.

While I’m not familiar with this equipment at all, I do reply with 32 years of EW experience with the USAF.

RFI can be a difficult thing to diagnose and repair. Cables, circuit board components, pins/header pins, and any attached devices can all contribute to/cause RFI.

LOL, I’m old enough to remember when mom used her electric beater, the TV in the other room would go haywire (although, depending on what she was mixing, licking the beaters was worth it) :slight_smile:


So, it would seem that this component could be the cause of the noise. Do you have spare that you can hook up to test?

I would say only if the cables were shielded, although moving away from that display couldn’t hurt.

I don’t know about that; I also don’t understand the reasoning of using a USB cable to connect to an antenna in the first place-all the add-on stuff for RPi radio playing that I’ve seen (GPS timing, ADS-B, etc) all use antennas with coaxial cable.


While I don’t use Manjaro/Arch Arm, I have this in my /boot/config.txt; no use for wifi/bluetooth on my pi:


There might be systemd units you can disable/mask.