Disable beep when logging in

I used pactl to get rid of the annoying motherboard sound every time I make a mistake, and replace the beep with bell.oga

However this fix doesn’t seem to carry over to the login screen. On the login screen, I still hear the beeping noise when I press backspace too many times. I tried using cron and xset b off, but that ended up turning off the bell completely (the computer won’t beep even if I do xset b off and then use the beep command).

How do I replace the motherboard beep on the login screen with bell.oga?

The speaker can be disabled. Look at the module pcspkr and blacklist it.

For more info: PC speaker - ArchWiki

This solution works and is the most straightforward. However, OP (and myself included) is more of interested in replacing the beep with a sound file.