DirectX 11 Steam games not launching due to unsupported GPU after Syu

I’m a bit inexperienced so bear with me please

Recently any Steam games using directX 11 will give an error along the lines of “Unsupported GPU for Dx11” and refuse to launch. Everything worked fine prior to a pacman -Syu, which upgraded about 500 packages.

I’m using the video-nvidia-470xx driver with a GTX 1070, which is definitely supported. glxinfo says that my GPU supports direct rendering and DX11 games launched anywhere else don’t work either.

I’ve tried reinstalling drivers, reinstalling Steam, and using the PROTON_USE_WINED3D=1, which works but doesn’t really solve my problem.

Any help would be appreciated, even if it’s just a hint on where to start :slight_smile:

Can you post inxi -Fza and mhwd -li ?

  Kernel: 6.4.2-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.4-x86_64
    root=UUID=2ce75909-556a-4493-b991-17185bcd9afd rw quiet splash
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: N/A v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Gigabyte model: Z77X-UD3H serial: <superuser required>
    BIOS: American Megatrends v: F18 date: 10/24/2012
  Info: model: Intel Core i7-3770K bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2656 high: 3428 min/max: 1600/3900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3428 2: 3007 3: 1969
    4: 3159 5: 3417 6: 2511 7: 1770 8: 1987 bogomips: 56083
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 470.199.02
    alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1b81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.87x11.85")
    s-diag: 610mm (24")
  Monitor-1: HDMI-0 res: 1920x1080 dpi: 93 size: 527x296mm (20.75x11.65")
    diag: 604mm (23.8") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 470.199.02 renderer: NVIDIA GeForce GTX
    1070/PCIe/SSE2 direct-render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: Gigabyte 7 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1e20 class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10f0 class-ID: 0403
  Device-3: SteelSeries ApS Arctis 5
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-3:2 chip-ID: 1038:12aa class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.4.2-3-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.73 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Qualcomm Atheros AR8161 Gigabit Ethernet vendor: Gigabyte
    driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 06:00.0 chip-ID: 1969:1091 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 2.26 TiB used: 1.57 TiB (69.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 model: SATA SSD size: 223.57 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: BB.3 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM008-2FR102
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: 0001 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Intel model: SSDSC2CT240A4
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 335u scheme: GPT
  ID-1: / raw-size: 223.57 GiB size: 219 GiB (97.96%) used: 194.08 GiB (88.6%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 55 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 37%
  Processes: 253 Uptime: 2h 2m wakeups: 0 Memory: total: 16 GiB
  available: 15.58 GiB used: 7.06 GiB (45.3%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 alt: 12
  clang: 15.0.7 Packages: 1483 pm: pacman pkgs: 1464 libs: 378
  tools: pacaur,pamac pm: rpm pkgs: 0 pm: flatpak pkgs: 19 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.28


> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-470xx            2023.03.23               false            PCI

Warning: No installed USB configs!

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Can you install a LTS kernel like 6.1.xx ?

1 Like

Installed, no change

I tried a newer kernel during troubleshooting and I guess it never changed back.

Why don’t you use the latest driver ?

Such as?

Are there any errors running the following? (Requires vulkan-tools):


That’s default now in recent versions of Proton.

That is only useful to enable DLSS & Ray Tracing which is only available with DirectX 12.

470 is the latest driver that shows up in mhwd -l

PROTON_USE_WINED3D=1 has Wine use OpenGL instead of Vulcan, I found it on a similar issue and it seems to work, but doesn’t solve the underlying problem

PROTON_HIDE_NVAPI=0 PROTON_ENABLE_NVAPI=1 %command% Doesn’t seem to change anything

I’ve tested with Deep Rock Galactic, Battlebit Remastered, Apex Legends, and Hunt: Showdown. They all give very similar errors along the lines of “No supported GPU found.”

vulkaninfo --summary returns:


Vulkan Instance Version: 1.3.255

Instance Extensions: count = 20
VK_EXT_acquire_xlib_display            : extension revision 1
VK_EXT_debug_report                    : extension revision 9
VK_EXT_debug_utils                     : extension revision 2
VK_EXT_direct_mode_display             : extension revision 1
VK_EXT_display_surface_counter         : extension revision 1
VK_KHR_device_group_creation           : extension revision 1
VK_KHR_display                         : extension revision 23
VK_KHR_external_fence_capabilities     : extension revision 1
VK_KHR_external_memory_capabilities    : extension revision 1
VK_KHR_external_semaphore_capabilities : extension revision 1
VK_KHR_get_display_properties2         : extension revision 1
VK_KHR_get_physical_device_properties2 : extension revision 2
VK_KHR_get_surface_capabilities2       : extension revision 1
VK_KHR_portability_enumeration         : extension revision 1
VK_KHR_surface                         : extension revision 25
VK_KHR_surface_protected_capabilities  : extension revision 1
VK_KHR_wayland_surface                 : extension revision 6
VK_KHR_xcb_surface                     : extension revision 6
VK_KHR_xlib_surface                    : extension revision 6
VK_LUNARG_direct_driver_loading        : extension revision 1

Instance Layers: count = 7
VK_LAYER_MANGOAPP_overlay         Mangoapp Layer               1.3.0    version 1
VK_LAYER_MANGOHUD_overlay_x86_64  Vulkan Hud Overlay           1.3.0    version 1
VK_LAYER_NV_optimus               NVIDIA Optimus layer         1.2.175  version 1
VK_LAYER_VALVE_steam_fossilize_32 Steam Pipeline Caching Layer 1.3.207  version 1
VK_LAYER_VALVE_steam_fossilize_64 Steam Pipeline Caching Layer 1.3.207  version 1
VK_LAYER_VALVE_steam_overlay_32   Steam Overlay Layer          1.3.207  version 1
VK_LAYER_VALVE_steam_overlay_64   Steam Overlay Layer          1.3.207  version 1

        apiVersion         = 1.2.175
        driverVersion      = 470.199.2.0
        vendorID           = 0x10de
        deviceID           = 0x1b81
        deviceType         = PHYSICAL_DEVICE_TYPE_DISCRETE_GPU
        deviceName         = NVIDIA GeForce GTX 1070
        driverID           = DRIVER_ID_NVIDIA_PROPRIETARY
        driverName         = NVIDIA
        driverInfo         = 470.199.02
        conformanceVersion =
        deviceUUID         = 419bed22-06e6-396c-8d27-ebbe66419e65
        driverUUID         = 352857eb-77c4-f2ac-f8b4-e21d4f7e72fb

The full version is 1400 lines long but I can post it if it would be helpful

That can’t be right. Your GTX 1070 supports the current 535 series driver as inxi displays above:

Automatically installing the driver should install the video-nvidia profile instead of video-nvidia-470xx.

If running the above says the driver profile is already installed, you can do it manually by removing the current 470xx driver, installing the current 535 driver and rebooting:

sudo mhwd -r pci video-nvidia-470xx
sudo mhwd -i pci video-nvidia

…the normal output. :+1:

Check ProtonDB for each game and see if there are any relevant reports and/or instructions.

I switched drivers to 407 during troubleshooting, I just switched back to video-nvidia and nothing changed.

ProtonDB says nothing about my problem

PROTON_USE_WINED3D=1 %command%
Have you set the %command% ?

Alright, I’ve come to the conclusion that my system is borked and I need to backup and reinstall.

Very sorry to anyone who may stumble across this in the future.

EDIT: Just kidding, I still need help

Hello, i have/had same problem, but i have snapshots of the system before and after, is there any way that i can help?

Strange i tried to roll-back but this isue is still there.
But i have my steam lib on different partition and it is not rolled back.

I will try uninstall, steam delete SteamLibrary from another drive and then i will make an update.

Same, this did nothing, but i noticed that proton 7.x.x work without problems.
I will try to do clean install.

Well on clean it’s working.
But i don’t understand why it don’t work after restoring to snapshot, it worked tomorrow but but thru snapshot today it don’t.

Installing 6.4.3-1 Kernel didn’t helped.

I noticed that @Microwave2848 have GTX1070, same as i do.

Well, nah as Microwave2848 did i surrender too, gonna do it Windows-style.

Or so i said.
Now i do have “good” and “bad” snapshot.
There is possibility that it is Kvantum is one to blame.
There will be update.

So after a couple of hours and 2L of cola I discovered next:
This problem occurs from one/all/couple of next factors - video-nvidia-470xx, Kvantum Manager, Kvantum Manager + Layan theme.

Well duck looks like the problem was all along in “video-nvidia-470xx”, but I ducking certain that I did try to change them before.

Well this kinda sucks, with newest drivers or unable to use my display`s 165hz mode and only 120hz one is available.

I can confirm this problem but it’s not really new. The 470 driver suffer of this from few versions but it was depending on the game. I was switching months ago to the latest driver to fix this issue. I think that may be reliable to maintaining old cards in the 470 driver.

Okay I’m back after a reinstall of Manjaro and the issue is still here. I presume it’s a hardware issue but if other people are also experiencing it then it may be something else. Any help would be appreciated.


Well i have GTX 1070 to, so i think it should be somehow related.

What is your reason for using 470? Is 5XX was ever available for you?

Do older proton version work for you? In my case i was able to start DRG and Space Engineers with 7.0-6, when GE, Experimental and 8.0-2 caused SE and DRG to throw DX11 error.