Directly Booting into Windows without showing grub screen

I'm having a hp laptop(2018) with Windows 10 pre-installed. I made a 60GB separate partition for installation Manjaro by shrinking my main storage of 1TB. I installed Manjaro successfully. But the problem was , everytime I've to manually press F9 to change BootOrder to launch Manjaro otherwise it'll boot into Windows.

What I did so far.


° Disabled fast boot
°Disbaled Secure boot and cleared it's keys
°Installed grub and and updated
°Tried to edit {bootmgr} in Windows with bcdedit

But after setting up grub, I did see Manjaro in my BootOrder. I suddenly made it as 1st. But, it's still Booting Windows. And when I booted into BIOS later, the Manjaro entry disappeared.


Can someone please help me?:disappointed_relieved::tired_face:

1 Like

See if ‘efibootmgr’ you have both manjaro and windows entries.
Make manjaro the default (efibootmgr -o xxxx,yyyy) if it is not.

If above does not ‘stick’ (say after reboots), check out the 2 links.
Link 1
Link 2

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark