Device "UUID" Not found you are being dropped into an emergency shell

Help needed. I read through all the posts similar to this problem and they suggested solutions that I am unable to do because the utilities they call for are all “not found”

This is a new install on a HP all in one. I made a boot drive with Pahvo on it and it installed fine, but when I went to reboot, I keep getting put into the emergency shell.

Other posts talk about needing to add VMD because it might have intel RSD to my modules but in the emergency shell I can’t access any text editors and Sudo is also not found. I tried Fsck and that can’t find any drives, but ls on the UUID shows two drives /sda1 and 2.

Boot installer screen shows Manjaro as a boot option but it also kicks me out to the emergency shell when I select that option…
I am just past a newbie (used Ubuntu, mint and Manjaro for about 10 years), but step by step help is probably needed.


It needs to be done in manjaro-chroot, while booted in the live USB.

This is a known issue with Manjaro / Arch, while some other distros already implement their own fixes by including the proper modules by default, universally for all installations.

Hopefully, this is done as a patch for future Manjaro installers:

Here is another thread in which I go through the step-by-step with some more detail:

A live USB session is done by booting from the flash drive, is that correct? I get booted out before I am able to have the option to choose that option. Is there another way to get to that environment?

BTW, thanks for the super fast reply!

How did you install Manjaro in the first place if you can’t even boot into the live USB? :question:

What are your system specs?

When I did the install, I had no problem loading from the live usb. However, since it asked for the reboot, I have not been able to do so. I can interrupt the boot and get to the grub menu and the hp set up screen but that has been about it.

8 GB Ram
Originally had Win 10
HP All in one
Manjaro Pavho
Not sure what else you need, but let me know and I’ll see if I can look it up.

But why not just hold down ESC (or whatever it is, F2? F9? F10? F11?) while the system is powering on in order to bring up the EFI boot override menu? Then you can select your stick instead of booting from the drive.

I have done that but when I get to the boot override, it starts to load then say UUID not found and drops me into emergency shell again. Just tried a couple times again and it still keeps droping me into the shell

I’m confused by this part. Did you boot into the live USB then run the installer and successfully install Manjaro?


I was just able to boot into the live usb. Only took about a dozen attempts but I am there.

I will go back to your other posts and add the line and reboot.

If you get stuck or confused by any of the steps, let me know in here! :crossed_fingers:

Thanks, I’ll let you know the outcome one way or the other.

OK, not my night. Per the instruction, I tried to mount root, boot and esp, each time it came back as can’t find in /etc/fstab
I then tried to use manjaro-chroot -a and it came back as grub-probe error: cannot find a GRUB drive for /dev/sda1 check your device map
Mounting [/dev/nvme0n1p2]
–>mount: [/mnt]
–>mount [mnt/boot/efi

Can you share the exact command you used while in the chroot jail?

cd /mnt
mount /root

Same for the other two

Apologies! Those instructions make assumptions that the user is familair with fundemental commands in the terminal.

First of all, before you can enter the chroot, you need to mount your persistent system’s “/” and “/boot/efi/” under the temporary directory, /mnt, and /mnt/boot/efi, respectively.

In your case, it might look like this, depending on your disk layout

sudo mount /dev/nvme0n1p2 /mnt
sudo mount /dev/nvme0n1p1 /mnt/boot/efi

You should be able to enter the chroot jail now,

sudo manjaro-chroot /mnt

ok, I put in the first two and they just seemed to do ok.
sudo manjaro-chroot /mnt says command not found

Try without “sudo”.

came back
bash: manjaro-chroot: command not found

Is this in the live session, booted from the USB? :flushed:

One other thing, when I originally did the chroot command, it seemed to have worked, but the prompt went from green manjaro@manjaro to red manjaro