"Device UUID=... not found" nach Installation eines neuen Kernels

Hallo!

Vor ein paar Tagen habe ich mir ein weiteres gebrauchtes Thinkpad zum Herumspielen zugelegt und die aktuelle Manjaro GNOME 21.0.7 darauf als alleiniges OS installiert.

Nachdem das System dann soweit lief, dass ich damit arbeiten konnte, wollte ich (weil ich’s kann :laughing:) einen neuen (5.12) Kernel zusätzlich zum vorhandenen 5.10 installieren.

Nach der Installation und einem anschließenden Neustart bootete das System nicht mehr und schickte mich konsequent in eine Emergency Shell:

Info: Die Systempartition ist mit LUKS verschl√ľsselt, /boot unverschl√ľsselt. (Mit verschl√ľsseltem /boot bootete das System sehr, bzw. mir, zu langsam.)

Was ich bereits erfolglos gesucht, gefunden und probiert habe:

  1. Start vom Installationsmedium, mount der /boot-Partition und der LUKS-Partition, manjaro-chroot ins System

  2. Dort dann Abgleich der Ausgabe von blkid und dem Inhalt von /etc/fstab: Die UUIDs passen bzw. sind identisch.

  3. Neuinstallation von grub, anschließend die grub.cfg in /boot/grub/grub.cfg mit Hilfe von grub-mkconfig -o /boot/grub/grub.cfg neu erstellt.

  4. In meiner Not dann sogar den 5.12er-Kernel wieder deinstalliert, schließlich hatte das Unheil damit begonnen. :smiley:

Tja, nur leider hat nichts davon zum Erfolg gef√ľhrt. Eine erneute Neuinstallation m√∂chte ich nach M√∂glichkeit vermeiden, da das System fast vollst√§ndig nach meinen W√ľnschen konfiguriert ist.

Was kann ich noch tun? Ich stehe gerade wirklich auf dem Schlauch…

Danke f√ľr eure Hilfe!

Moin,
als ersten Schritt w√ľrde ich den Eintrag f√ľr die Platte aus fstab auskommentieren, damit du zumindest wieder in dein ‚Äúnormales‚ÄĚ OS kommst. Von da aus kann man dann weiter schauen :wink:

Das ist kein Problem vom Kernel oder grub, sondern weil die UUID, die in fstab steht nicht gefunden wird (das kann einige Gr√ľnde haben).

Also in der rescueshell: nano /etc/fstab
Dann den betroffenen Eintrag mit einem ‚Äú#‚ÄĚ auskommentieren.

Das ganze nat√ľrlich in der Hoffnung, dass das nicht dein Root-Filesystem ist.

Dummerweise ist es die root-Partition…

Direkt als /dev/xxxx anstatt mit UUID ansprechen.

Was ändere ich da wo? In der grub.cfg?

So, habe in den sauren Apfel gebissen und Manjaro neu installiert. Ging einigerma√üen z√ľgig.

Genau. F√ľr ein Test reicht es beim Booten Shift zu dr√ľcken Dann Eintrag ausw√§hlen und E dr√ľcken.Hier einfach √§ndern und wenns passt fest Eintragen.