Device Recognition in Google Accounts

I’m really trying to understand beneath situation:

When I login in my Manjaro device (old windows x86_64 laptop, configured and installed to be used only with/in Linux Manjaro) it will be recognized by Google (Accounts) as a “Linux system” when logged in (in Manjaro) with Manjaro Admin account, but it will be recognized by Google (Accounts) as a “Windows machine” when logged in (in Manjaro) with a normal user account.
I used to login in Google Accounts with my web browser (Firefox).

  1. What is the global impact (on the internet) when A) using my (Linux) admin account on the internet or B) using a normal (non-admin) user account?

  2. Does above also mean that a normal Manjaro user account is more ‘vulnerable’ than a Manjaro admin account, while it is more specifically be recognized by Google Accounts?
    What does it mean?

WHY are you doing this?

Why not?

If you need that explained to you, you are using the wrong OS.


I just need it to be explained because I want to learn and understand!
Will you and can you (trying to) explain me?

And by the way, Manjaro is 100% the right OS for me :wink:

First, could you please clarify what you mean by “admin user”. If it is root, it is no good. As one of the first and most effective security brick in linux is not to use root as a login user.

This way it way more difficult to abuse software bugs or tricking human bugs in front of the desk to do things it/you shouldn’t. An as graphical applications are by far more complex and error prone as the administrative console commands is is more likely that a graphical application might be abused if it has to extensive rights.

If you mean admin user is a normal user with sudo permissions, that’s ok.

Hope this clarifies things a bit.

To get back to the base question, I’m not shure how google detects the OS. Easiest would by by user-agent header. You might check if this is different on both users for whatever reason.

Thx for your feedback.
Many times I use my sudo account (admin/system-user) to read my google mail.
As far as I know, root is only and explicitly be used offline and that very rare.
So that’s not a (big) problem I think.

I just installed freshly the latest LTS version of Manjaro with all the newest (non-RT) kernels.
I believe the ‘flaw’ is solved in this new release, because now Google does NOT see the difference anymore regardless I use a normal user account or a administrator (not Root, but sudo rights) account.
In both cases it sees a installed Linux system. So that’s a good change I think.

But…I still don’t know WHAT has changed what caused it, but for now the ‘problem’ is solved.
I’m still open for an answer…

I still need to correct the above, it should be:
In both cases it sees a installed Windows system.

Unknown if this should normally be expected in stead of being detected as a Linux system…