"device did not show up after 30 sec" on Install

I am a new Linux user wanting to do a dual boot with Windows 10 on my laptop. (With a plan to use only Linux once I feel comfortable with it.)
Once I boot from my USB drive I get the welcome screen and select “Install with open source drivers” (or something like that). After that I get a black screen with a big Lenovo logo (just as when booting Windows). After about 30 seconds I get this error:
“ERROR: ’ /dev.disk/by-label/MANJARO_KDE_2021’ device did not show up after 30 seconds…
Falling back to interactive prompt”

I’ve looked other places with no luck. I noticed that as soon as the Lenovo logo appears the light on my USB drive turns off and doesn’t come back on. I have validated my ISO and used Rufus to burn it.

Welcome here, @Gquirt

Here are some tutorials to review:

Thanks for the timely response.

I looked at the second tutorial and it seemed to show how to write the ISO using Linux CLI. I only have Windows installed at the moment, and thus couldn’t follow the second tutorial. (I have followed other tutorials I found and I am pretty sure I did that part right.)

I then followed the preparation steps in the first tutorial and was successful. I got stuck in the same place as before: In Calamares I select “boot with open source drivers,” get the Lenovo logo, and the same error. I think it has something to do with my computer not communicating with my USB drive after I select the boot option because as soon as I do the indicator light on the USB drive turns off.

I did skip the step about adjusting time zones because a lot of it needed to be done from Linux and not Windows.

Any more help would be appreciated.

Hello @Gquirt :wink:

No idea why, but Manjaro ISOs don’t work good with Rufus. You have to write Manjaro in raw format to the flash drive, not on a fat32 partition. Rufus should be able to do this.

Use win32diskimager or ventoy is much easier and has really great support.

I tried using Ventoy with a similar result. I got through Ventoy menu and tried to boot. The light on my USB drive stayed on a few seconds longer, but this time it just stayed on the Lenovo logo. After a few minutes of just the Lenovo logo, I gave up and shut my computer down. Multiple tries have yielded the same result.

As a side note, Rufus is one of the recommended programs in the Manjaro User Guide. This probably isn’t the place to mention it, but someone should probably get that changed if it doesn’t work for most people.

UPDATE: I did a bit more testing. I used my USB drive and tried to boot on another computer and it booted straight to the Manjaro desktop like it should. Now at least we know that it is an issue with some type of settings on my laptop and not something wrong with my USB drive or ISO.

After the error code I am left with a command line that seems to work. I have tried a few commands and gotten responses. Following an idea from a different thread, I ran “cd /dev/disk/by-label” and “ls” I saw my hard drive listed, but not the USB drive.

I’ve heard rumors that Lenovo laptops don’t always cooperate well with installing Linux very well. Maybe there is something Lenovo specific that I need to do? I have an AMD Ryzen 3700U processor. Most of the tutorials only mentioned specific things to do with Intel processors. Is that because works with Linux better than Intel or because until recently AMD was a lot more obscure?

I did the strangest thing and it worked. I knew that I had gotten a different version of Linux to live boot off of a SD card using a USB adapter before. So I put Manjaro on a micro SD card and used a USB adapter. After that I was able to boot to the desktop like I should. I still can’t figure out why the other USB drive didn’t work on my laptop when it works with other computers, but I’m just happy I got it to work.

I actually wrote this from the live boot USB drive. Now on to the Install!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.