Desktop won't boot into Manjaro and only gets to Grub with Ubuntu, while it can boot into Windows

Also I couldn’t find secure boot in the BIOS:

How can I install os prober from Ubuntu Grub, given that I can’t actually boot into Ubuntu, just Grub?

then you need to boot into live media of manjaro
and follow this guide
https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

go to advanced settings these are basic settings you are looking at.

As I said I can’t find it anywhere in the BIOS, including in all possible windows in Advanced settings.

UEFI? Bios-legacy? gpt? msdos? Both? :open_mouth:

The BIOS is UEFI.

1 Like

I will need to find the CD to boot with it before I can continue.

If you can start from a grub, say in your case the Ubuntu grub, you don’t need a livecd. You can use that Ubuntu grub, go to its grub prompt and start from step 4 there.

Good luck. Cheers.

OK, I’ll try that, thanks.

1 Like

get this tool and throw it on an USB Stick Super Grub. Have it ready and tested before you proceed.
From your bcdedit output i can see, that the winbootloader ist still in the path. When I installed Manjaro on my surface, i had to point this entry to the Manjaro boot loader. Here is how:
Mount the EFI Partition in Windows and check for the Manjaro grubloader: (superuser Powershell)

$ mountvol s: /s
$ s:
$ cd efi
$ ls

In your case the last comman should show

manjaro
Microsoft
ubuntu

Make a note of the path and description of your bcdedit output. Just in case you have to revert it.
Issue command on Powershell

bcdedit /set '{bootmgr}' /path \EFI\manjaro\grubx64.efi

You can use TAB for autocomplete like in a linux Bash but make sure to get rid of the Drive letter “S:”.
Give it a description

$ bcdedit /set '{bootmgr}' description "Manjaro 64"

or whatever description you prefer.
Reboot. Manjaro should boot now. Do a:

$ sudo grub-install
$ sudo update-grub

Reboot. Now you should see all your three OS’s in the grub screen.
Let us no the outcome.

I find it easiest on a EFI system to just install grub once per OS and install the rEFInd boot manager to select which os I want to boot from everytime my computer restarts.

So create an ESP, install grub to it from Ubuntu AND manjaro. You will be able to select whether you want to boot to windows OR grub from manjaro, or ubuntu at boot time. This is an easy solution that allows you to dual boot even more OSes, and skip grub’s OS prober and your bios config.Screenshot%20from%202018-06-16%2012-17-44

Yes! rEFInd is the tool that saved my but after installing The 17.10.0 Version of Mint. Locked up the BIOS. Biiiig mess last year. I managed to install the next version by using rEFIind and get it fixed. In order to get rEFInd to work you have to make the entry I mentioned earlier with bcdedit or have it installed via a booted Linux. It’s a brain jerking thing anyways. Super Grub, somehow, let’s you sit back and think.

Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

PS C:\WINDOWS\system32> mountvol s: /s
PS C:\WINDOWS\system32> s:
PS S:\> cd efi
PS S:\efi> ls


    Directory: S:\efi


Mode                LastWriteTime         Length Name
----                -------------         ------ ----
d-----        8/09/2017   7:21 AM                Microsoft
d-----       21/10/2017   6:06 AM                Boot
d-----        9/11/2017   1:58 AM                ubuntu

PS S:\efi> bcdedit

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=S:
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {54675401-7078-11e8-aae4-99dc52f1ebda}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \WINDOWS\system32\winload.efi
description             Windows 10
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {54675403-7078-11e8-aae4-99dc52f1ebda}
displaymessageoverride  Recovery
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \WINDOWS
resumeobject            {54675401-7078-11e8-aae4-99dc52f1ebda}
nx                      OptIn
bootmenupolicy          Standard
PS S:\efi> bcdedit /set '{bootmgr}' /path \EFI\manjaro\grubx64.efi
The set command specified is not valid.
Run "bcdedit /?" for command line assistance.
The parameter is incorrect.
PS S:\efi> cd Boot
PS S:\efi\Boot> ls


    Directory: S:\efi\Boot


Mode                LastWriteTime         Length Name
----                -------------         ------ ----
-a----       25/03/2018   9:38 AM        1111928 bootx64.efi
-a----       30/01/2018   6:52 AM          79856 fbx64.efi


PS S:\efi\Boot>

Wow! Looks like Manjaro did not install at all. Or it tries to use the ubuntu grub to run. This will not work. Did you create that super grub usb drive? if so, u will be able to boot manjaro from there. Then to the grub install and update stuff.

So I was able to boot into Manjaro, thanks! Via step 4, I got to the OS menu with Manjaro at the top, and then the next screen said error: grug/grub/env not found. However it then went to the boot screen:

As an aside, is this normal? It happens every time when booting.

I’ll update in a minute with some more info…

james at james-pc in ~
$ sudo grub-install /dev/sda
[sudo] password for james: 
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

james at james-pc in ~
$ sudo update-grub
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found Windows Boot Manager on /dev/sda1@/efi/Microsoft/Boot/bootmgfw.efi
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

get rid of the /dev/sda after grub-install.