Desktop pauses, jerky video, running hot, kswapd


#1

KDE, Thinkpad T60 Intel T5500
Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller driver: i915

One small issue noticed, as reported with the previous Stable Update:
Video playback on Youtube with Firefox is getting choppy and laggy after a few minutes.
This did not happen with the second last Stable Update.

Also the fan is running much more and much longer.
With the second last update the fan came on only rarely, and if at the lowest level for a short time.
Now the fan is running at an audible level, most of the time. Even when Youtube is not palying back video.

There must be a performance regression since the last Stable Update.


[Stable Update] 2018-04-02 - Kernels, ZFS, Pamac, Udisks2
#2

Check your process usage with e.g. top.

Also clean out your heatsinks and fans.

Please dig into this to find which package/s is/are the culprits.


#3

jonathon,

Thank you for your reply. I can assure you the heatsinks and fans are free of dust.

Using top, while running a Youtube video full screen in Firefox, I can see :
approx 90% CPU ±20% for process “Web Content”
approx 50% CPU ±10% for process “firefox”
approx 10% CPR for XOrg

… on a Thinkpad T60 with an Intel® Core™2 Duo Prozessor T5500, 64bit.

IMO it is firefox in combination Youtube and/or a performance issue with i915 graphics driver.
No other programms/packages have been started. Even while I am writing this message after a test run of a Youtube video the T60 feels noticably warm and fan keeps on running.
Two Stable Updates before, the very same T60 was running Youtube videos smoothly and cool.


#4

OK, have a check through this:


#5

johnatthon,
whatching top while playing a youtube video, to me it seem the problem is related to
root kswapd0
and maybe also
root khugepaged0
Whenever kswapd0 turns up at the top of the list, the youtube video hangs of jitters. Now - while typing this message - even after the youtube video was stopped with heavy lag, the typing of character into this forum is delayed by up to one second! And the mouse is jumping. This has to be something deep down in the system.


#6

Your out of memory.
If your computer starts swapping, everything goes to slowmotion.
You could try to close everything your don’t need to ahve open.
Buy more RAM.
Type
free
in konsole
free
total used free shared buff/cache available
Mem: 16247364 6240732 7034440 400788 2972192 9969732
Swap: 0 0 0


#7

Swap. You’ve run out of RAM.

You’re running too many applications at the same time.


#8

that is strange. top is displaying 1GB free of 2GB RAM total.
and as I said: before 2 Stable Updads this system was running smooth and cool while playing Youtube videos.
Another guess could be that the SSD is aging, since being stressed by the updates.


#9

Correction:
There are actually only 0.1 GB RAM free. Something is eating RAM and sometimes the the RAM does recover, sometimes not.

On the other hand the active processes
WebContent and firefox are using 30% RAM each. 30% each stable, not growing.
There are no other processes running, except 2 other tabs in Firefox, with wikipedia and the Manjaro frorum.


#10

To document the mem usage:
GB RAM free of 2GB total RAM:
1.5 … Firefox closed
1.0 … Firefox open, blank page
0.8 … Youtube openend
0.5 … plus Manjaro Forum opened
0.4 … plus YT video started in small window (not maximised)
then
0.1 … after 10 mins of YT video, continuing too loose memory
[Update]
closing the YT-tab in firefox returns to only
0.3 … after approx 20 seconds
1,2 … only after closing firefox (was 1.5 before)
[/Update]

To me it seems YT / firefox has a memory leak.

The other symptom is, that the T60 is running at higher temperatures than before the second last Stable Update.


#11

It looks like perfectly normal RAM use to me. What is a “leak” is probably cache, unless you’re measuring correctly and with a clean, fresh browser profile.


#12

jonathon.

you might be right.
Using YouTube/Opera works like a charm on my T60 with 2GB RAM. I have tested this now for an hour. Opera is using less CPU and ab little bit less memory, than Firefox.

What still remains is, that the T60 runs noticably warmer and with more fan comparded to two Stable Updates before.


#13

There have been 5 extra updates for mesa/intel vulkan and a firefox update, which have not been mentioned in the Stable Updates forum with a separate post.
Do we know what those updates were about?

After a test with YT/firefox, subjectively my T60 with 2GB RAM runs now the same (means cool and silent) as before 2 Stable Updates. No jitter with Youtube videos on firefox anymore after more than 10 mins of playback.


#14

Firefox update is a Firefox update.


#15

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.