Desktop/Panel gone

I’m experiencing this, no wallpaper, no panels, no widgets, no right-clicks, super key does nothing.

I can only see the Plank dock and work via Plank and terminal.

Neofetch for basic info:

OS: Manjaro Linux x86_64 
Host: HP Pavilion Gaming Laptop 15-dk0xxx
Kernel: 5.8.11-1-MANJARO 
Uptime: 21 mins 
Packages: 1318 (pacman) 
Shell: bash 5.0.18 
Resolution: 1920x1080 
DE: Plasma 
WM: KWin 
WM Theme: Sweet-Dark-transparent
Theme: Breath2 Plasma], Breath-Dark [GTK2/3]
Icons: Flatery-Indigo-Dark [Plasma], Flatery-Indigo-Dark [GTK2/3] 
Terminal: konsole 
Terminal Font: Noto Mono 10 
CPU: Intel i7-9750H (12) @ 4.500GHz 
GPU: Intel UHD Graphics 630 
GPU: NVIDIA GeForce GTX 1650 Mobile / Max-Q 
Memory: 1863MiB / 15851MiB 

EDIT: This happened when rebooting after performing some pamac updates (I hadn’t updated form a couple weeks).

EDIT 2: Playing around with plasmashell I got to see my wallpaper blink for a second and some errors, see this pastebin. Can confirm that kquitapp5 plasmashell returns "Application plasmashell could not be found using service org.kde.plasmashell and path /MainApplication." and then kstart5 plasmashell produces the same output as in the pastebin.

EDIT 3: This might have something to do with me previously using this workaround for my widgets and messing up with ~/.config/plasma-org.kde.plasma.desktop-appletsrc. I have disabled the script and rebooyted, and I have also tried deleting the file but the issue persists.

Maybe this will help you…



Do you use eventcalendar widgget? I beieve it is about the widget.
Removing the widget may fix the problem:

rm -rf ~/.local/share/plasma/plasmoids/org.kde.plasma.eventcalendar

Then you can install eventcalendar v.69 from AUR, as its developer informs.

The issue is discussed here in several posts:


@chomsky @ceres

Thanks! It was indeed due to the Event Calendar widget. Everything’s back on its right place now. I will definitely try to use the v.69 from AUR as I really liked the widget.

EDIT: Version 69 from AUR works perfectly!
EDIT 2: Well, not perfectly. For some reason I’m not able wo make the key binding work. It becomes “None” again after saving changes.


Shortcut also works for me. By the way, I couldn’t realize that a shortcut woud be handy. Thank you, I have a shortcut now :slight_smile:

1 Like

Thank you, I had the same issue and this was just the solution I was looking for. I’ll give a try to the v.69, I hope it has the same functionality because I use it a lot.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.