Desktop not loading after boot login, but can still use terminal and programs

Yesterday my pc crashed during a system update and I had to reboot, which caused a problem in loading the kernel that I already figured out.
But when the system booted to the login screen and I thought it would be ok, after logging it only shows a black screen with the cursor.
The thing is, if I press F12 I get the shell terminal from which I can open firefox, and I’m using it right now to make this post, only the desktop is not showing, so I figure it may not be a problem in Nvidia’s driver
I don’t know where to begin solving this as I never tinkered with desktop environment, how can I begin to troubleshoot?

rerun update first:
sudo pacman -Syyu

Already did it
says there is nothing to do

so post output from:
mhwd-kernel -li && mhwd -l && mhwd -li

mhwd-kernel -li                                                                                                                                                                               ✔  7s  
Currently running: 5.15.65-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux510
   * linux515

mhwd -l  :heavy_check_mark:

0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:

              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

0000:01:00.0 (0300:10de:1c02) Display controller nVidia Corporation:

              NAME               VERSION          FREEDRIVER           TYPE

      video-nvidia            2021.11.04               false            PCI
video-nvidia-470xx            2021.11.04               false            PCI
video-nvidia-390xx            2021.11.26               false            PCI
       video-linux            2018.05.04                true            PCI
 video-modesetting            2020.01.13                true            PCI
        video-vesa            2017.03.12                true            PCI
mhwd -li                                                                                                                                                                                             ✔ 
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

formatting got weird for some reason but I guess it’s okay

Couldn’t my problem be with the desktop packages? How can I reinstall them?

could be some messed up plasma conf… can you enter system settings?

I don’t know the name of the program so I can start it with the terminal :confused:

type systemsettings

I’m in it, the appearance selected configs are the same as before

so under global settings, click default, check also desktop layout, click apply - this will reset your theme

Theme changed from breath dark to breath
I think I may have to reinstall my DE packages

that will not probably help …open dolphin and rename the .cache folder to .cahce.bak then reboot

did you mean .cahce or .cache?
What it’s supposed to do?

yes cache.bak
there are issues with plasma after update, like buggy plasma and what you have, so deleting cache could help with it

Still the same
What if I reinstalled plasma? Is that difficult?

you can do it:

sudo pacman -S plasma kio-extras sddm manjaro-kde-settings plasma5-themes-breath sddm-breath-theme 


Everything was followed with “exists in filesystem”
And the last line was

Errors occurred, no packages were upgraded.

Can’t scroll up enough to see what happened the terminal was flooded with the packages that it tried to install

it should have reinstalled it …
run that command with overwrite:

sudo pacman -S plasma kio-extras sddm manjaro-kde-settings plasma5-themes-breath sddm-breath-theme --overwrite '*'

You did it my man
Took some time to load, probably because it was the first time loading after reinstall, but it’s all good now
thanks a lot for your time and patience!!

lets hope that it is fixed … but these exist in filesystem errors - you may have more of them …
try to install something, doesnt matter what, just to test if you can do it without issues …