.desktop extension only pulls up text editor

Good evening,
I have been having some issues with this for about a day or so. Installed tor browser and when I run the


it only pulls up Kate text editor.

I have checked all permissions and file properties to run as an executable. All good. Compared it to other Manjaro KDE installs I have and they work fine and all the settings that I see are the same.

Interesting thing to note is when I try to open the


shell script in the same directory it opens Kate as well. This leads me to believe it is a configuration setting on my system. I can run the script from konsole and it pulls up the browser so I know it works…

I have googled and searched and found nothing helpful. I was hoping y’all could help me out.

Thanks in advance. Merry Christmas!

start-tor-browser.desktop is not in good directory ? can use ~/.local/share/applications/

Can you post the contents of both files?
Plus the location you installed the tor browser?

Can you be more specific in “How you open” those files?

Check if this post from the old Forum helps:

Worked like a charm! Thank you much sir.

I wonder how it got changed or stopped working? It’s a fairly new install, so I am not sure if I had time to mess it up yet :stuck_out_tongue:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.