Desktop Effects being disabled after 5.21, only in Manjaro

I have a strange issue and would be open to any ideas anyone has.

After upgrading to 5.21, Desktop Effects are constantly disabled after the computer wakes up from sleep.

I get a notification from Kwin saying: “Desktop Effects have been disabled by another application.”

I have no idea what application that is or why its disabling Kwin (I’m guessing its a power saving app that triggers sleep maybe?)

I did a test run of KDE Neon for several days and Desktop Effects werent’ disabled there. I also tested Solus, and didn’t encounter the issue there either.

I’m guessing its something in Manjaro that 5.21 isn’t playing nice with.

Does anyone have any clue why this is happening or what I can do?

I’m running an AMD gpu using the open source drivers. I know this sounds like a trivial issue but part of the appeal of Plasma is the polish you get with Desktop Effects.

1 Like

Thank you for that feedback.

1.) I don’t have anything of the sort runnign while the computer goes to sleep. Largely when I step away its either LibreOffice or Firefox, or nothing (all apps closed, except for default background tasks set up by the OS)

2.) I thought about that, but I do use my computer for gaming. I’m not sure what hit on performance that would have, but it would have one nonetheless. So that’s why I didn’t choose to select that option.

Also, it becomes a problem with hot corners if they’re still active during gaming, and you’re waving your mouse around the screen and accidentally activating hot corners.

Is there a way to diagnose which application is causing Kwin to disable destkop effects? As I said, I tried a fresh install of Manjaro, tried to create an identical setup in KDE Neon, then tried Solus (in case it was only an issue with a newer kernel). I’ve only had the problem in Manjaro.

Start with a fresh boot, then sleep and see what happens.
Then start looking at autostart stuff.

I remember this issue - but I can’t remember WHEN it was, maybe 2 years ago, or what brought it on.

I also recommend looking at using MOUSE gestures instead of simple hot corners - it’s especially good for days when you have your mouse on the bed or sofa and it goes sliding whilst you’re typing :rofl:

This means for a ‘top left’ hot corner, I just move as if I’m going to activate it, but hold down the right mouse button when I do it - so I actually draw that line just an inch on the screen (anywhere) and it activates that key combination.

I use Easystroke, but you can do it in KDE shortcut settings too.

Are you referring to Settings → Startup & Shutdown → Autostart, or is there a different place you’re referring to?

If the former, the place is empty; I think yakuake and the welcome screen are the only things that Manjaro itself sets up, and I have both disabled.

Mouse gestures seem like a good thing to explore, I’ll do that.

I’m not a big menu user - I just hit krunner, or menu, and type ‘autostart’… but yes, it’s in Startup and Shutdown.

Hmm…as i said that place is empty. Do you have any other idea of what I can do?

Same problem after updating. But I think that it is not that the animations were deactivated, it is that they happen so quickly that they are imperseptible

I definitely get a notificaiton saying that effects have been disabled. And things like transparency, hot corners, and stuff don’t work. And i get a bunch of screen tearing.

I did try to play around with animation speeds hoping it would resolve it, unfortunately it didn’t seem to.

I also have no desktop effects whatsover since a couple of weeks now. The issue is present at startup and not only after wake from sleep .

Interesting, do you know if its after the 5.21 update?

Also just to cover all bases, I’m sure you already know this, but just making sure all the basics are checked: If you go to Settings → Display and Monitor → Compositor

Is the box “Enable compositor at startup” checked?

Well I’ll be damned that fixed it for me! Thanks dude!
Makes me wonder why the compositor box got unchecked.

I often use the following shortcuts to quickly ‘refresh’ stuff - which I bound to mouse gestures…

  1. Restart kwin - kwin_x11 --replace &
  2. Restart plasmashell plasmashell --replace
  3. Toggle compositing Alt+Shift+F12
  4. Hide decorations ctrl+Alt+j (good when tiling)

So did you try the Alt+Shift+F12 to restart compositing after it’s blocked?

Generally I find replacing kwin kickstarts stuff like compositing if it crashed.

Hiding decorations is a useful one if you use tiling (krohnkite) but don’t want to disable decorations there (menu’s going to globalmenu) - it lets you run an app ‘fullscreen’ when it’s not really fullscreen (issues with some apps, and with ‘always on top’ status).

Why can’t the notification specify WHICH app (e.g. when exiting Plasma I used to get specific message saying 'qbittorrent disabled it; not ‘an application’).

This is something that a quick search didn’t reveal…

Any clues in the journal? something like journalctl -p 3 -x

That’s awesome, glad it worked :slight_smile:

Hey Ben,

Thank you so much for the detailed suggestions.

  1. I didn’t mention it in this post, but in the Kwin notification, it also says “Press alt+shift+f12 to reenable desktop effects.”

I tried that for about 3 weeks, but it just became so unbelievably cumbersome. I know that sounds unbelievable, but my initial reaction was: “fine if there’s no solution, its only a 3 button combo, I can do it everytime.”

But it just wore me down. Which is utterly bizarre, but I did try to just live with it for a long time.

I perfectly agree with you on why won’t the notificaiton just tell me which app is doing it. I even tried on a fresh install of Manjaro (well that’s not exactly true, after a fresh install and my basic setup which includes installing a few things like feathernotes)

Also thanks for the journal command (I’m not proficient in the terminal so I didn’t know about it) but it doesnt’ seem to turn up anything.

I also tried looking through the logs, but they didn’t seem to say anything either.

I have another interesting update: I just installed Manjaro again, and walked away for a second.

Meaning that no software installed, no updates done on my end, all settings as default.

I came back to a locked screen (which I disable as this is my home computer).

And I found the same message and that desktop effects were disabled.

I have no idea what’s going on, screen locking isn’t a power saving feature (is it?). The computer isn’t going to sleep (as that isn’t a default setting), its just the screen is “shutting off/switching” to either off mode or lock mode.

Default installation sets screen off after 5 minutes and lock by default.

No idea why desktop effects were disabled though.

I’m facing the same problem. First I thought it was a configuration problem so I made a fresh install (when I say fresh it is totally fresh I’ve formated everything including config files in home) and the problem persists.

  • Every time the screen saver tries to start, desktop effects are suspended and the monitors light up again. Then i f I wait again the monitors goes to sleep 5 minutes later. I say monitors as I’m using two monitors.
  • It can happens sometimes when I play a game in full screen but this isn’t systematic.
  • Something else every window displayed on the second screen moves to first screen ??? (the first time it tries to go to sleep mode)

I had’nt this bug with the same hardware and the previous version.

I too have an amd graphic card and use free drivers.

I’d like to chime in and say that I’ve experienced this same issue with Plasma 5.21, however not on my Manjaro system but rather my Kubuntu system (had this in 20.04, 20.10, and 21.04). I’ve also experienced KDE messing up the configuration of my desktop panels of my left-most monitor when waking up from sleep.

I’m not sure if these are related, since I was able to track down the issue with the panel with the plasmashellrc not properly assigning the connectors, however fixing that does not fix the desktop effects and transparency (this includes a restart of plasmashell). The only way that I’ve been able to fix the desktop effects not working is to go to “System Settings → Display and Monitor → Compositor” and to switch the “Rendering backend” to another option and hit “Apply.” This happens on both OpenGL 3.1 and OpenGL 2.1, but switching from one to the other resolves the problem. Restarting the compositor, either by “Shift+Alt+F12”, or running qdbus org.kde.KWin /Compositor suspend; qdbus org.kde.KWin /Compositor resume, does not fix this problem.

I’ve done enough to that Kubuntu system that any of these kind of bugs I chalk up to running a less standard configuration since this wasn’t an issue for me on my Manjaro laptop.

To outline the Kubuntu system:

OS: Kubuntu 21.04
Kernel: 5.11
Resolution: 1920x1080 x3
WM: Kwin
DE: KDE Plasma 5.21.4
CPU: AMD Ryzen 9 3900x
GPU: AMD Radeon Pro WX 2100 (amdgpu driver)
GPU: Nvidia GTX 1080 (proprietary 460.91.03)

Some of the quirks of this system:

  • Both the AMD and Nvidia drivers are loaded on boot, however amdgpu is tagged as the default GPU for X. Nvidia is left around for PRIME offloading, and is dynamically unloaded for a GPU passthrough.
  • The left display is connected to both GPUs, and can be effectively hot swapped by changing the source whenever I launch the VM.
  • The middle display is connected only to the AMD GPU.
  • The right display is connected to the AMD GPU through a KVM which can be hot-swapped between two other systems.

This happens when I have booted and only ever run the system from the amdgpu driver (no nvidia unloads/reloads), and when I haven’t toggled to another system through my KVM. It basically always happens when resuming from being locked when I step away, but I know can happen under other circumstances where I can’t identify a culprit. “Enable compositor on startup” is enabled, and “Allow applications to block compositing” is disabled.

I figured I’d leave this here since it isn’t a Manjaro only issue, and figured that it might be helpful to see what the similarities are (multi monitor/amgpu etc).

I have to confess I skipped most of the thread, but on KDE there is an old issue with the desktop effect disabling after some specific condition (like plugging a secondary monitor, enabling/changing screen resolution, things like that…). The bug can be avoided if you enable a Desktop Effect called Background Contrast. After enabling it I don’t see a change in the desktop itself, what it changes seem to be minimal, however it fixed ALL the related crashes of desktop effect in my case. Just try and see.

So thank you for keeping this thread going.

I’d like to chime in and share a “solution” I’ve discovered.

I noticed that desktop effects were disabled whenever power saving feature was “interrupted.”

So as I said in my post, screen off at 10 min, sleep at 15 min.

Screen-off never worked right for me for a long time (definitely pre 5.21, but can’t say when). Screen would flicker after 10 min, but come back on, and then go to sleep with the system at 15.

I noticed one time when I sat down at my computer just as the screensaver was being turned “on,” that as it flickered, desktop effects were disabled.

If I deactivated screen-off and just left sleep (main pwoer saving feature) activated, desktop effects are working fine for me for several days now.

Another data point (though its sporadic) is I have qbittorent set to over system sleep…the same thing happens with it (I think, as I don’t torrent too much so I can’t say with certainty). If qbit goes on for long enough, system begins to sleep, qbit itnerrupts and keeps system awake.

From a user point of view, what I see is the screen temporarily flicker.

But again, desktop effects are disabled!

There’s something of value here, maybe poeple who know more than me can use it to debug.

But the solution for me has been: deactivate screen-off and only rely on sleep