Desktop destroyed

Hello, I started my laptop and see, my desktop is destroyed. I doesn’t load bg image, the windows are fixed at the corner, I can’t close windows because the program bars disappeared… I can’t click any thing cuz the mouse is just an X. Didn’t see this before. I didn’t change anything at the system and I didn’t update anything. What can I do?

Please help me. It’s urgent and I have very important data on my desktop!

Can’t post screenshot links, can’t upload. It’s so stupid sorry. So unfortunately I can’t provide pictures l.

This sounds strange if its really xfce. Could it be that you choose a different ‘Desktop Enviorment’ at your Login screen?

This sounds like a Tiling Manager (i3, Sway or Awesome). :slightly_smiling_face:

inxi -Fazy | curl -F 'file=@-'

Do you still have all necessary packages installed?

pacman -Qsq xfce

Ctrl+Q should work with most applications.

You could check your drive status. If no warning shows up, your data should be fine.

Hello @Yzga and welcome :wink:

Easy and simple fix: Create a new user account.

  1. Switch to another TTY: CTRL+ALT+F3
  2. Login there
  3. Run: sudo systemctl isolate rescue and type blindly the root password + ENTER
  4. Create a new user account:
useradd -m newusername
  1. Create a new password: passwd newusername and type blindly the user password + ENTER

  2. Close the rescue mode:

  1. Restart the display-manager:
sudo systemctl restart display-manager
  1. Login with the new username.

When it is running again normally. You can move your files from the other account.

If that does not help… I would rather think that the HDD or Filesystem is damaged.


Welcome to the forum! :wave:

Your topic title is not appropriate. Please edit it with something more descriptive of the problem and remove the exaggerated cry for help.

Please see:

Thx to all

Step 0 didn’t work. It doesn’t happen anything

StrG q doesn’t work.
Don’t know what’s happening here

I think my hdd is OK

Would you please explain This command after the pipe, what it is supposed to do??
inxi -Fazy | curl -F ‘file=@-’

1 Like

title edited

tl;dr - try deleting the .cache directory in your home directory.

I had a very similar issue occur to me this morning. It was pretty infuriating. One day things were going fine, the next I couldn’t move windows, Alt-Tab, etc.

To ensure this wasn’t a system-wide issue, I created a new user account (the graphical way). Everything worked there. @megavolt suggested copying over all my files… nope, too many small configurations to go down that rabbit hole without trying harder. Surely there is something simple that went wrong that can be adjusted?

First I dug around in my .config/xfce4 directory. I diffed it with the working version—no meaningful differences to speak of. I backed it up and replaced it with a copy from some /etc/ skel directory following directions I found online. Logout, login… nope, that just got rid of the Manjaro start menu icon and put the mouse there instead.

Then I dug around in the broader .config directory. Deleted a bunch of unnecessary stuff (I used wine only briefly and uninstalled it, so toodeloo to that config directory) and copied important stuff from the working new user account. Logout, login… nope, didn’t fix anything.

Then I looked at the dot-directories in my home directory. I deleted my .cache directory, my .cpanm directory, and maybe one or two others. I was about to go through my .local directory but I screwed up what minimal window tiling I had working for me and had to logout and login. Voila! My title bars are back! So, I’m pretty sure it had to do with the .cache directory.

1 Like

Hm … broked user profile creates borked desktop. True enough.
(considering it didnt happen to everyone … it happened for some special reason and needed cleaning)


xfwm4 --replace

If not sufficient try:

sudo rm .Xauthority
sudo rm .ICEauthority
sudo rm .xsession-errors*
sudo reboot

xfwm4 --replace worked for me, thanks!

1 Like