Desktop applications running in terminal in Manjaro Sway

Thanks for this update - looking forward to it.

As intermediate solution you can try to install silver-git package from the AUR repo. Looks like this has been upgraded a couple of weeks ago and should work fine.

Just did a test in an extremely large folder… scrolling is not an issue in Thunar for me. Works well with the external Bluetooth mouse and with the 2-finger swipe on the integrated touchpad.

Just a hint: touchpad is configured to ‘natural scrolling’ behaviour by default - means you will have to swipe up for the content to move down…

I already switched to Nautilus and Thunar scroll problems are not an issue anymore with me either. Just to your information, I was not able to scroll up or down with the touchpad; swiping up or down didn’t matter.

Since removing Thunar and its related dependencies, my system feels more stable. I have lesser freezes and screen gargling; those white screen with black dots reminiscent of those old tvs. So, I am keeping my current configuration. The screen garglin is occuring sometimes with firefox, so I am switching to chromium to minimize the problem. The only move that I am delaying is moving from Termite to Gnome Terminal. I guess this move will need some extra tweaking; that is one reason why I am delaying.

I will wait for the next Manjaro Sway image; I will make a fresh install using it as a base; and make my tweaks, e.g. remove xfce, install gnome files, rhythmbox etc depending on whether I still have the issues. I will also make the decision on termite next month.

I have other usability issues with sway such as lack of clipboard manager, caffeine like application. But they belong to another thread.

Actually found an interesting way to make this work on Sway…

First of all it requires a change to your local .profile setting to extend the path variable to .local/bin…

# expand user path to local/bin for xterm link
export PATH=$HOME/.local/bin:$PATH

Then during the login the Sway auto start scripts can automatically generate a bash script named xterm in that directory that will call into your configured terminal…

My sway config as follows:

# styles - matcha-green or matcha-blue
set $theme /etc/sway/themes/matcha-blue

# Your preferred terminal emulator
set $term termite --config=$theme/termite

will create a bash script .local/bin/xterm with the content:

termite -c /etc/sway/themes/matcha-blue/termite -e "$2"

With that in place… as soon as I try to start a terminal application from Wofi it will trigger the xterm script with the selected executable…

1 Like

Done in profile: [sway] xterm emulation to enable terminal apps from wofi (64ecade0) · Commits · manjaro-arm / applications / arm-profiles · GitLab

Ok, great.

Made a new image with these changes today. Please check post in: Screenlock and swayidle problems

you should push a delta update file for test image.