Desktop applications running in terminal in Manjaro Sway

With Sway I would recommend Kitty or Terminology

I personally use kitty because there is a good integration with Ranger filemanager (for instance to view images inside ranger instead of in a w3m window).

Terminology is a bit bigger but has more options like in terminal picture and video support.

Whatever terminal you use. As showed in you other thread it can be resolved with desktop.entry file. The issue you have now according to that is that with Neovim it does not seem to fill the whole terminal. Which is odd since the other apps you tested had no problem.

That seems to be the issue now or am I incorrect?

Kitty and Alacritty needs OpenGL3 to work and are only able to be executed with some custom environment flags in place at the moment (see [ARM Stable Update] 2020-10-27 - KDE Plasma, Firefox, Uboots and Kernels).

I gave Alacritty a try with these overrides and noticed that neovim behaves in a proper way with it. So the issue might be related to termite not reporting screen space on-time for neovim to catch up… doing a force screen refresh usually results in neovim catching up in termite though.

So sorry, I dont run ARM but Sway is no stranger to me. Thanks for the link learned something new :slight_smile:

1 Like

Yes, I also have other problems with termite; e.g. when I write a long command and termite is open side by side with another application, the command ends up repeating at the same line overwriting the powerline prompt etc. This can also be relevant to the symptom.

That may be a poweline silver issue. I had such experience. Then I uninstalled powerline silver and switched to zsh with oh-my-zsh. Since then no command prompt glitches.

The wofi-ranger issue was solved for me by installing and configuring xterm. I really like how ranger and w3m can render images in terminal.

EDIT: I made an mistake, I wrote “powerline” but meant “silver” and the issue @appelgriebsch mentioned in following comment. Sorry.

I would not prefer to install another terminal application; esp. xterm in my Sway environment; I would prefer the terminal application to be Wayland native.

I have used Powerline with Gnome Terminal and Xfce Terminal in the past. I did not have the symptom. I tend to think it is a Termite problem. It may be relevant to the symptom because it may be the case that Termite is not encountering the available space it occupies.

If I have to switch to another Terminal program, I would prefer it to be Gnome Terminal. Actually, Gnome Terminal is also mentioned as an option in Sway wiki. Besides being mature enough, it is Wayland application and it didn’t request to install any dependency when I tested it in my Sway environment.

Terminal is an important part of the deal especially when it comes to using a keyboard driven lightweight wm like Sway. I hope we could have a good terminal program soon. On the side, I am still considering to switch to Gnome Terminal. Fonts and powerline do not seem as polished as in Termite, but I assume this could be fixed.

Similar problem with Termite here. The terminal only went 15 digits (using half screen) before returning back on itself overwriting the prompt. However when in full screen this does not happen. Following this thread I tried to install terminology, but it did not go so well. It seems to require a lot of manual configuring. Any suggestions for a newbie?

IMHO Alacritty would be a very good alternative to termite and my preferred terminal emulator, but as said above it uses some OpenGL3 functionalities that are still only available behind some feature flags on the Panfrost driver of the Pinebook Pro…

Therefore it might need more testing before making it the default in the Sway image.

Also take other devices, like Raspberry Pi and Odroids into account here. :slight_smile:

1 Like

Please note that there is a bug report for the Silver prompt in GH for this… Line wrapping issue with silver in termite (using bash) · Issue #58 · reujab/silver · GitHub.

Looks like it has been solved already, but we are still waiting for a new release of it (which should include this bugfix).

Thanks for this update - looking forward to it.

As intermediate solution you can try to install silver-git package from the AUR repo. Looks like this has been upgraded a couple of weeks ago and should work fine.

Just did a test in an extremely large folder… scrolling is not an issue in Thunar for me. Works well with the external Bluetooth mouse and with the 2-finger swipe on the integrated touchpad.

Just a hint: touchpad is configured to ‘natural scrolling’ behaviour by default - means you will have to swipe up for the content to move down…

I already switched to Nautilus and Thunar scroll problems are not an issue anymore with me either. Just to your information, I was not able to scroll up or down with the touchpad; swiping up or down didn’t matter.

Since removing Thunar and its related dependencies, my system feels more stable. I have lesser freezes and screen gargling; those white screen with black dots reminiscent of those old tvs. So, I am keeping my current configuration. The screen garglin is occuring sometimes with firefox, so I am switching to chromium to minimize the problem. The only move that I am delaying is moving from Termite to Gnome Terminal. I guess this move will need some extra tweaking; that is one reason why I am delaying.

I will wait for the next Manjaro Sway image; I will make a fresh install using it as a base; and make my tweaks, e.g. remove xfce, install gnome files, rhythmbox etc depending on whether I still have the issues. I will also make the decision on termite next month.

I have other usability issues with sway such as lack of clipboard manager, caffeine like application. But they belong to another thread.

Actually found an interesting way to make this work on Sway…

First of all it requires a change to your local .profile setting to extend the path variable to .local/bin…

# expand user path to local/bin for xterm link
export PATH=$HOME/.local/bin:$PATH

Then during the login the Sway auto start scripts can automatically generate a bash script named xterm in that directory that will call into your configured terminal…

My sway config as follows:

# styles - matcha-green or matcha-blue
set $theme /etc/sway/themes/matcha-blue

# Your preferred terminal emulator
set $term termite --config=$theme/termite

will create a bash script .local/bin/xterm with the content:

termite -c /etc/sway/themes/matcha-blue/termite -e "$2"

With that in place… as soon as I try to start a terminal application from Wofi it will trigger the xterm script with the selected executable…

1 Like

Done in profile: [sway] xterm emulation to enable terminal apps from wofi (64ecade0) · Commits · manjaro-arm / applications / arm-profiles · GitLab

Ok, great.

Made a new image with these changes today. Please check post in: Screenlock and swayidle problems

you should push a delta update file for test image.