Dependency Hell: Cannot update to Manjaro 24

warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "akonadi"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "akonadi"
warning: ignoring package ki18n-6.1.0-1
warning: cannot resolve "ki18n", a dependency of "akonadi"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kcrash"
warning: cannot resolve "kcrash", a dependency of "akonadi"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "libakonadi"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "libakonadi"
warning: ignoring package ki18n-6.1.0-1
warning: cannot resolve "ki18n", a dependency of "libakonadi"
warning: ignoring package kcmutils-6.1.0-1
warning: cannot resolve "kcmutils", a dependency of "kaccounts-integration"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "kaccounts-integration"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kaccounts-integration"
warning: ignoring package ki18n-6.1.0-1
warning: cannot resolve "ki18n", a dependency of "kaccounts-integration"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kauth"
warning: ignoring package kwindowsystem-6.1.0-1
warning: cannot resolve "kwindowsystem", a dependency of "kauth"
warning: cannot resolve "kauth", a dependency of "kio"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "kbookmarks"
warning: ignoring package kcolorscheme-6.1.0-1
warning: cannot resolve "kcolorscheme", a dependency of "kconfigwidgets"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "kconfigwidgets"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kconfigwidgets"
warning: ignoring package ki18n-6.1.0-1
warning: cannot resolve "ki18n", a dependency of "kconfigwidgets"
warning: ignoring package kwidgetsaddons-6.1.0-1
warning: cannot resolve "kwidgetsaddons", a dependency of "kconfigwidgets"
warning: cannot resolve "kconfigwidgets", a dependency of "kbookmarks"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kbookmarks"
warning: ignoring package kwidgetsaddons-6.1.0-1
warning: cannot resolve "kwidgetsaddons", a dependency of "kbookmarks"
warning: cannot resolve "kbookmarks", a dependency of "kio"
warning: ignoring package kcolorscheme-6.1.0-1
warning: cannot resolve "kcolorscheme", a dependency of "kio"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "kcompletion"
warning: ignoring package kwidgetsaddons-6.1.0-1
warning: cannot resolve "kwidgetsaddons", a dependency of "kcompletion"
warning: cannot resolve "kcompletion", a dependency of "kio"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "kio"
warning: ignoring package kcolorscheme-6.1.0-1
warning: cannot resolve "kcolorscheme", a dependency of "kconfigwidgets"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "kconfigwidgets"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kconfigwidgets"
warning: ignoring package ki18n-6.1.0-1
warning: cannot resolve "ki18n", a dependency of "kconfigwidgets"
warning: ignoring package kwidgetsaddons-6.1.0-1
warning: cannot resolve "kwidgetsaddons", a dependency of "kconfigwidgets"
warning: cannot resolve "kconfigwidgets", a dependency of "kio"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kio"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kcrash"
warning: cannot resolve "kcrash", a dependency of "kio"
warning: ignoring package kguiaddons-6.1.0-1
warning: cannot resolve "kguiaddons", a dependency of "kio"
warning: ignoring package ki18n-6.1.0-1
warning: cannot resolve "ki18n", a dependency of "kio"
warning: ignoring package kiconthemes-6.1.0-1
warning: cannot resolve "kiconthemes", a dependency of "kio"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kjobwidgets"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "knotifications"
warning: cannot resolve "knotifications", a dependency of "kjobwidgets"
warning: ignoring package kwidgetsaddons-6.1.0-1
warning: cannot resolve "kwidgetsaddons", a dependency of "kjobwidgets"
warning: cannot resolve "kjobwidgets", a dependency of "kio"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "kservice"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kservice"
warning: ignoring package ki18n-6.1.0-1
warning: cannot resolve "ki18n", a dependency of "kservice"
warning: cannot resolve "kservice", a dependency of "kio"
warning: ignoring package kcolorscheme-6.1.0-1
warning: cannot resolve "kcolorscheme", a dependency of "kwallet"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "kwallet"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kwallet"
warning: ignoring package ki18n-6.1.0-1
warning: cannot resolve "ki18n", a dependency of "kwallet"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "knotifications"
warning: cannot resolve "knotifications", a dependency of "kwallet"
warning: ignoring package kwidgetsaddons-6.1.0-1
warning: cannot resolve "kwidgetsaddons", a dependency of "kwallet"
warning: ignoring package kwindowsystem-6.1.0-1
warning: cannot resolve "kwindowsystem", a dependency of "kwallet"
warning: cannot resolve "kwallet", a dependency of "kio"
warning: ignoring package kwidgetsaddons-6.1.0-1
warning: cannot resolve "kwidgetsaddons", a dependency of "kio"
warning: ignoring package kwindowsystem-6.1.0-1
warning: cannot resolve "kwindowsystem", a dependency of "kio"
warning: cannot resolve "kio", a dependency of "kaccounts-integration"
warning: ignoring package kirigami-6.1.0-1
warning: cannot resolve "kirigami", a dependency of "kaccounts-integration"
warning: ignoring package kcolorscheme-6.1.0-1
warning: cannot resolve "kcolorscheme", a dependency of "kwallet"
warning: ignoring package kconfig-6.1.0-1
warning: cannot resolve "kconfig", a dependency of "kwallet"
warning: ignoring package kcoreaddons-6.1.0-1
warning: cannot resolve "kcoreaddons", a dependency of "kwallet"
warning: ignoring package ki18n-6.1.0-1

The above just prints forever. Suggestions? Never had an issue with an update until now, and until the latest release, I was up to date.

sudo pacman-mirrors --continent && sudo pacman -Syu

Nice. Packages seem to be downloading now. Going to nuke my themes & try to install from TTY now. Wish me luck

2 Likes

Good luck. :slight_smile:
You will probably also want to remove kde-frameworks-5 packages not needed by anything.
(it is expected you will still have some kept, but this will target the unneeded)

sudo pacman -Ru kf5

Maybe check orphans

pacman -Qdt

Remove them

sudo pacman -Rns $(pacman -Qdtq)

You may be similarly interested in ‘foreign’ packages.
(some may have been dropped to the AUR and are no longer needed)

pacman -Qm

And then theres the usual ‘clear cache and configs’ steps that can be performed
https://wiki.archlinux.org/title/KDE#Configuration_related

If for some reason you have any issues make sure you are using compatible themes, widgets, etc.

And if you must you can go hunting in ~/.local/share for any remnants of kde/plasma stuff to remove.

1 Like

Yeah… I think removing the KDE5 packages may be necessary. I was using yay to update, pacman apparently downloads the packages first and will probably throw the same errors after making me wait to download nearly 4GB.

But I dont know if you can beforehand without removing a bunch of plasma.

I dont think so?

I have a feeling your original trouble may be related to AUR packages.

(which pacman does not interact with)

In any case we wont know unless we see the logs.

If the attempt fails then please share the relevant bits.

You can find the logs in /var/log/pacman.log.

Also here is a guide for sending things to pastebins

I think yay was the issue. I was able to upgrade with pacman, however it crashed part way through and required manual intervention (deleting file conflicts). Going to take a bit of tweaking to get my plasma config back where it was, but I am running Plasma 6 now…

It probably means you had/have unsupported packages that were trying to pull from the AUR.

Take care to remove unneeded packages.

The file conflicts speak to other issues like running sudo pip at some point, etc.

So fully up to date then? Huzzah.

I’m pretty sure the file conflicts were from pacman crashing… I wouldn’t have pip’d anything to do with /usr/lib/initpico/whatever

Something is still wrong tho… application styles (updated for qt6) aren’t applying, nor are icons

You mean you apply an icon theme and it does not work?
Or ? …

that’s what I mean

But like how?
You select a theme and it fails to apply? Or some icons are missing in places? Or?

Which theme?

Every instance of something like this reported on the forums so far has either been crud in HOME (.cache, .config, etc), or simply an incompatible theme.

‘Breeze’ should work. I know ‘Papirus’ (not papirus-adapta or the manjaro one) does as well.

Here is mine;

Papirus is the theme I"m trying to apply

I think I’m going to restore from timeshift and try again another time

If you have already performed the ‘refresh’ steps then it may still be something in your ~/.local/share.
Maybe some Papirus folder already installed to ~/.local/share/icons ?

What refresh steps do you mean? And what should I remove from .cache?

I’ll try a couple more things before giving up.

It’s like it’s stuck using kavantum, even though i’ve uninstalled it

timeshift opened with the arc theme, and I’ve uinstalled that as well (after prompting sudo password)

woo alright, I fixed it… went back and saw the link you posted

QT_QPA_PLATFORMTHEME was set

1 Like