Dependency failed for swap

When booting up, I get a couple of black screen flashes with the title message.

sudo systemctl --failed returns

 UNIT                                                                      LOAD   ACTIVE SUB    DESCRIPTION                                           
● dev-disk-by\x2duuid-b25981f7\x2d0a68\x2d4ca5\x2db998\x2d91e9e4290033.swap loaded failed failed /dev/disk/by-uuid/b25981f7-0a68-4ca5-b998-91e9e4290033

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.

/etc/fstab contents

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=EEFA-C9C4                            /boot/efi      vfat    umask=0077 0 2
UUID=324426ca-5875-4818-97b8-d4413b765086 /              ext4    defaults,noatime 0 1
UUID=b25981f7-0a68-4ca5-b998-91e9e4290033 swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

I’ve read the thread Failed to activate swap - On boot, but still not sure what to do for my specific issue.

Can anyone provide some input on solving this please? Tyvm.

make it to be

UUID=b25981f7-0a68-4ca5-b998-91e9e4290033 none           swap    defaults 0 0

More on Swap - ArchWiki

Tried this but still seeing the same behavior.

Are you also using systemd-swap ? Don’t mix them. Is either one or the other, or a swapfile, or zram-generator
also make sure the UUID=device_UUID is the correct one for the swap partition.

I don’t know to be honest. How would I check this?

Check if systemd-swap or zram-generator are installed and remove them. Reboot after that.
From your screenshot it seems the UUID is correct.

Don’t see either of those

Please check with the Pamac UI, no need for screenshots. Also the location is not correct for systemd-swap. Is in
Also, if arch wiki was not helpful, check our wiki Swap - Manjaro

Checked for /usr/lib/systemd/system/systemd-swap.service, not there.

If I were to delete the swap partition and recreate it, would this hurt anything?

The swapon command returns nothing.

Makes no sense. Did you reboot after editing fstab?

Yeah, doesn’t make sense. I just re-imaged. Thanks.