Dependencies stops installations

I’m a newbie in Manjaro, though I started using Linux Mint in 2006 or 2007. Always get trouble installing new programs in Manjaro cos of lacking Depencies stopping (!) or putting up obstacles during the installation, thus making Manjaro less usable, cos takes longer time to install programs or doesn’t install at all.Tried install Qemu in order to install Virtual Machine (Mac, & -probably- Linux Mint cos of the super quick support & I know the people. Mac Mountain Lion just to learn a bit of Unix programming. Newer Mac’s use diskrutil not Bash, I think). So it seems I cannot install Qemu full or basic. Might be cos this new Pine computer uses ARM CPU(not Intel, which the Linux tutor in a Youtube video mentioned as -possible- requirement for CPU &/or VM). If anyone can explain a workaround &/or a reason of this repeating Dependency challenge, please do.

Qemu is in a weird state on ARM these days, since the update to 7.0.

It currently can’t be installed on an ARM host, since it depends on a package that is not available in ARM.

Someone did make a PR to Arch Linux ARM to try and fix this:

But it’s had no response yet.

So the issue will be solved later, then?
I have no urgency installing VM & I can probably use Virtualbox for VM.
It was another reason I started it this time, cos selling my old Mac, thought I had to use it to install VM Mac Mountain Lion, but it is at least 2 reasons to not use the Mac for this at all. Also is that Mac is way more complicated to use than Linux Manjaro (or Mint, or Fossapup. Debian I tried, even bought a book about it, but finally dropped it; it always put up obstacles. Debian requires a lot of knowledge & time).

I don’t know to be honest. Keep an eye on that github PR to see what upstream wants to do.

Thanks for the info.
I will probably jump temporarily to anothe distro in the hope of finding Qemu available in Endeavour, Mint or Fossapup. Probably working in Mint. I will probably come back as soon as the issue with lacking ARM packages is sorted out. It is a challenge in general for me that installs of new programs always talk about dependencies, thus uses extra focus & time. But I can well live with that cos it usually solves it out itself.