Dell XPS 15 9570 with PRIME -> OS Freezes on wake up


#41

Maybe this will be of help.


#42

No output here

Logs are empty


#43

No nvidia-xrun or bbswitch packages are installed.


#44

does xrandr --listprovider also show intel or does it show modesetting?


#45

It seems to be nvidia

Providers: number : 2
Provider 0: id: 0x241 cap: 0x1, Source Output crtcs: 0 outputs: 0 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x46 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 4 associated providers: 1 name:modesetting


#46

before setting up prime, did you add any kernel parameters in grub, anything like?
“quiet resume=UUID=2a9f4626-7cc2-4835-b302-f58b13066cac acpi_osi="!Windows 2015"
or anything else video related?
im not too sure what effect this has (im guessing), alot of people with optimus laptops use parameters like that and similar to get around a blank screen or freezing at tlp .

check your grub config or reboot and when you get to grub hit “e” and that will show any kernel parameters you may have set on the line beginning with “Linux”. if there is anything like that, you can edit it out and continue boot (F10 i think*). grub will boot that 1 time without those parameters and nothing is saved permanently. if you want it permanent you would have to edit your grub config and update-grub. editing grub during boot is only temporary and reverts right back to its original state on next boot so i prefer to do it that way rather than in reverse, much more forgiving should you mess up.


#47

I didn’t add any parameters. I don’t have anything like

To sum up our current progress:
I can suspend my laptop and resume it without any problems. The solution to this was switching the sleep mode.
And now you guys see another problem, which was underlying my initial issue?
I’m fine with waiting for driver updates which might fix some issues.


#48

i guess you could, but have you tried benchmark/running games to see if your nvidia gpu is working properly? that, along with the curiosity of “why intel and not modesetting,nvidia?” was the reason i brought it up but if its all working well then and your happy with it nevermind.


#49

if you do look into it, compare your nvidia x server settings, heres what it shows on mine.


is your display shown as PRIME Display: eDP-1-1 ?


#50

Yes, my settings look exactly the same.


#51

I dont think you have any problem nor that you use intel driver instead of modesetting. If you would use intel one nvidia probably wouldn’t work at all


#52

I changed the solution to @dglt since he gave this first::wink:

Then it might be a bug in inxi?
Xorg log shows modesetting, so…

@jonryan can you check

lsmod | grep i915

#53

Sure :+1:

here my output:

i915                 2097152  3
i2c_algo_bit           16384  1 i915
drm_kms_helper        208896  2 nvidia_drm,i915
drm                   495616  14 drm_kms_helper,nvidia_drm,i915
intel_gtt              24576  1 i915


#54

And

cat /proc/cmdline

You might need to uninstall intel driver

pacman -Qs intel video

it should be something with xf86 I don’t remember the exact name (not being on PC now…)


#55

This is my cat /proc/cmdline

BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=f76c5faf-103e-4fd0-ac33-357ff9e65c02 rw quiet loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0 resume=UUID=9f333831-8f28-4b22-a102-fc8e123a7c58 mem_sleep_default=deep

It doesn’t look like anything like it is installed. There is no output wenn running pacman -Qs [...]


#56

You have a deprecated setup for silent grub.
Read the last Announcements instructions on the currently required parameters and adjust accordingly, for sure remove vga=current, update grub and reboot.


#57

I removed the part with “vga=current” but unfortunately, I couldn’t figure out which announcements you are referring to.


#58

Any, just check known issues regarding silent grub configuration


#59

Since my device boots normally I’m not sure what exactly I’m looking for or what you want to point out.


#60

Read how silent grub is configured. Your Grub parameters are from the older quiet grub testing package, that are not needed.

About Intel/modesetting, what video drivers do you have installed:

pacman -Qs xf86-video