[Dell XPS 15 9560] Freezing when selecting to reboot/shutdown



I haven’t used rEFInd so know very little about it, but using grub you don’t have to re-install the bootloader with manjaro-architect if it is already installed.

You just need to mount the EFI boot partition (ie to boot/efi) during the setup steps before base install, grub doesn’t need to be re-installed. You would then need to run sudo update-grub afterwards to re-generate the grub config and menu.

One of the benefits of using Manjaro is its Arch base and that much of the Arch wiki is directly applicable to Manjaro. Not all of it, like drivers and kernel config, but nearly all. It is a fantastic learning resource and probably the best place to look for info when you don’t understand something conceptually… rEFInd for instance…


or systemd



I have just deleted both my rEFInd and Manajro installs, and reinstalled both from scratch in Manjaro Archtiect, this time opting for systemd instead of openrc. Now when I boot into Manjaro, it hangs at “Started TLP system startup/shutdown” until I do a force shutdown by holding the power button. This is the exact same issue when I installed from the iso (as shown here).

This clearly is a problem relating to what I originally had earlier today using openrc, the only difference being that with openrc, I could actually boot into my desktop, but not be able to shutdown. Now I can’t even boot in.

Any ideas? Should I reinstall with openrc again and try to figure it out there?


There is some mention of that same error here on this forum:

Is there a reason you are using Architect rather than one of the officially supported methods?


Probably because of this?

As for the OP. I don’t think the systemd causing this issue, but rather the dual graphic cards in your system. In Architect, you could try to choose option 4 to install all free drivers. Then after installing it, use the fallback initramfs when booting. That way, I hope it will get past tlp startup/ issue shutdown


One of the other people reporting this just went into the bios and shut off the intel video.


Well, there are others who can’t do that since they’re using acer/asus laptop. But I think OP can do that since he’s using Dell XPS…


What graphics driver did you install? Free drivers I don’t think will work (ie nouveau).

If you wish to use your nvidia card I would recommend you select the proprietary bumblebee hybrid driver


or for the sake of simplicity, to get your installed system to boot just, select the intel driver


and the hybrid driver can be installed post install if you wish.

Booting from the ISO I assume you tried non free graphics drivers? I don’t think free drivers will boot with this machine.


You shouldn’t need to re-install your system just to change the graphics drivers installed

Boot into your manjaro-architect ISO and from the CLI chroot into your installed system, where sdXX is your root partition

sudo mount /dev/sdXX /mnt
sudo manjaro-chroot /mnt

Now check which mhwd driver is installed

mhwd -li

I just did this with a Virtualbox Manjaro VM, it worked well.

To install a different graphics driver using mhwd, remove the current one first, then install the new one. For example, if you have nouveau installed and want to replace with nvidia bumblebee

sudo mhwd -r pci video-nouveau
sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee

If you have nvidia bumblebee already installed and want only the intel driver to get your system booting

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-intel

I assume you installed the 4.11 kernel, to check

mhwd-kernel -li

If not then you can install it using

sudo mhwd-kernel -i linux411

Also, for the manjaro-architect ISO CLI you can run diagnostic commands

inxi -Fx
journalctl -p err -b

Pipe the results into text files, mount a USB drive, copy them, and post them here.

You can also check your xorg logs for errors in /var/log. Copy them and pastebin them here too.

Before you do all that piping and copying though, make sure you have the correct graphic driver installed first, and try booting into it.


This may be of help, other users on Reddit with your machine trying to get Live ISO to boot also.

This sounded encouraging…

Ok. I installed Manjaro with Manjaro Architect last night. working like charm now.

I think this is a graphics driver problem, as I mentioned in previous post, but you could always ask these reddit users the installation options they chose.

Bottom line is with this particular hardware system mhwd on ISO doesn’t handle it well currently.

I also found this on Arch wiki, an entry on your machine


just note that Manjaro graphic driver config is done differently in Arch, Manjaro uses mhwd, so take the graphics configuation section as conceptually instructional and not literal.


My Dell BIOS doesn’t seem to have that option.


Someone in my.other thread recommended that I use Architect because of the problems I was having. These new suggestions in this thread seem to say differently though, so I will try again later.


Thank you for the suggestions. I will try these when I am home from work.


I am attempting a fresh install through Architect again. Evidently, selecting the display drivers is the key step (I had previously selected the free drivers). There is an option to select which display drivers to install, so hopefully the video-hybrid-intel-nvidia-bumblee or video-intel options are listed in there, otherwise should I just go for the proprietary drivers, see if that works and then manually uninstall and install the other options through TTY if I still can’t boot?

I’ll update soon on how it goes!


I installed with the hybrid display drivers. Booted fine into KDE, first thing I tried was a reboot from the KDE power menu and all went smoothly! (See edit)

I will play around over the next day or so to try find any bugs, and will then post a full update for any future users with the same problem!

Thank you everyone in this thread for the help, especially @sueridgepipe and @jsamyth.


I jynxed it. When I said I rebooted and it all went fine, I meant that my laptop actually shutdown, which previously didn’t happen. I then booted into Windows to make sure that was all fine, then rebooted back into Manjaro and am getting the report during boot “psmouse serio1: synaptics: Unable to initialize device.” - which I have had trouble with before on previous Manjaro ISOs. After this the boot process hangs at “Started Hostname Service”. I have tried several times now, all with the same story.


Telling us something just doesn’t work is no help. You need to provide info.

Boot into your manjaro-architect ISO and get the following info

inxi -Fx
fdisk -l
journalctl -p err -b

Pastebin your xorg.0 and xorg.8 logs from /var/log

I highly recommend you read this thread very carefully, the Dell XPS 15 9560 doesn’t seem to play nicely with Linux. If you are experiencing issues, it is likely they have been discussed in there.


Found this.

It might be worth trying to blacklist psmouse module entirely. I’ve done so to remove the

dmesg error: psmouse serio1: synaptics: Unable to initialize device


Also read the Arch wiki entry for your machine above, which contains a number of workarounds for known issues.


After a break from trying to figure this out due to being too busy with work, I have decided to give the Manjaro installation another go. Before I get into it again, I came across this comment with regards to installing Arch on the Dell XPS 15 9560. Does this provide any light on the issue? Is it possible to downgrade the Nvidia drivers during install?


I finally got a perfectly stable installation of Manjaro two days ago. As of yet, absolutely everything is working as expected - I haven’t noticed a single issue. Due to the issue clearly being from the nVidia GPU, I installed with the Intel Only graphics drivers, and so the nVidia card is permanently disabled. My goal next is to install Bumblebee so that I can flawlessly turn the nVidia card on/off when needed.

I used Manjaro Architect to install, and followed this tutorial. Here is a detailed list of all the options I selected:

  • Init System: systemd
  • Kernel: linux411, yaourt + base-devel
  • DE: KDE Minimal
  • Display Drivers: Select Display Driver > intel-only
  • Bootloader: rEFInd


The issue has to do with the nvidia gpu having a chance (not all the time!) to lock up when manjaro wants to set it to sleep or wake it up (actually when shutting down it somehow tries to wake it up and fails). If you don’t want to use intel only, I got it working with acpi_rev_override=1 kernel parameter, which arch kernels ship support for (actually specifically for XPS https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=0e9b0dcf10e65293c75dc893ce90deb90a1f57f3).

closed #38

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.