[Dell XPS 15 9560] Freezing when selecting to reboot/shutdown



I use OpenRC, but systemd is the standard and used much more widely (and so has more support). Unless you have some reason for not using systemd, I’d suggest using it. Especially if you’re a newer user. Much of the system and many applications are built to use systemd these days, so it takes extra effort to make them work with OpenRC.


Kernel is 4.11.7-1. Would you recommend using a newer one as well - any specific release you could recommend? I just chose that one as it was what was used in the tutorials, but I don’t even know when that tutorial was dated from.


I think I am going to do a completely fresh install as I have already learnt plenty more in the last 24 hours.

The only issue I am now unsure when reinstalling is the fact that I already have rEFInd installed. Will this remain installed if I wipe my Manjaro root partition, and then when I reinstall I just mount the same Windows EFI partition as /boot/efi and choose to install no bootloader, and then rEFInd will recognise my fresh Manjaro install?

rc-status -a                                                                                                 
Runlevel: nonetwork
 local                                                                                                 [  started  ]
Runlevel: sysinit
 sysfs                                                                                                 [  started  ]
 devfs                                                                                                 [  started  ]
 udev                                                                                                  [  started  ]
 dmesg                                                                                                 [  started  ]
 kmod-static-nodes                                                                                     [  started  ]
 udev-trigger                                                                                          [  started  ]
Runlevel: default
 dbus                                                                                                  [  started  ]
 elogind                                                                                               [  started  ]
 NetworkManager                                                                                        [  started  ]
 acpid                                                                                                 [  started  ]
 cronie                                                                                                [  started  ]
 netmount                                                                                              [  started  ]
 xdm                                                                                                   [  started  ]
 local                                                                                                 [  started  ]
Runlevel: boot
 hwclock                                                                                               [  started  ]
 modules                                                                                               [  started  ]
 fsck                                                                                                  [  started  ]
 root                                                                                                  [  started  ]
 mtab                                                                                                  [  started  ]
 swap                                                                                                  [  started  ]
 localmount                                                                                            [  started  ]
 procfs                                                                                                [  started  ]
 binfmt                                                                                                [  started  ]
 sysctl                                                                                                [  started  ]
 bootmisc                                                                                              [  started  ]
 termencoding                                                                                          [  started  ]
 keymaps                                                                                               [  started  ]
 loopback                                                                                              [  started  ]
 net.lo                                                                                                [  started  ]
 consolefont                                                                                           [  started  ]
 hostname                                                                                              [  started  ]
 urandom                                                                                               [  started  ]
Runlevel: shutdown
 killprocs                                                                                             [  stopped  ]
 savecache                                                                                             [  stopped  ]
 mount-ro                                                                                              [  stopped  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 modules-load                                                                                          [  started  ]
 xdm-setup                                                                                             [  started  ]


I don’t know which tutorials you were following, but I’d tend to rely on what’s on the forum rather than a third-party site.


It actually was on this site, that’s why I was happy to trust it. I think I am going to do a full reinstall anyway, with systemd and a few other changes. I’ll post an update when I’ve done so, but I had the same shutdown/reboot issue on Antergos, so I’m inclined to think it’s more of an issue with my specific hardware (emphasised by the “Hardware Configuration” section of the settings app crashing whenever I try to open it).


Surprisingly Windows-esc. Not sure I’ve seen that exact sequence in Linux.
It sounds like it is trying to pop-up a dialog box asking for a password or confirmation of your intent to log out, but that part is failing so it just sits there.

This might be a problem with sddm or lightdm or what ever you ended up with as the DM (login screen thingie) on your install.

Having read the rest of the thread, I suggest you do as you mentioned and re-install into that same partition (using systemd) for your first go.

Side Note: The others (above) try to be neutral about systemd/OpernRC, but OpenRC’s sole raison d’etre is political animosity and hide bound resistance to change. One of the principal designers of systemd had all the personality of a cactus in an outhouse, and ruffled a lot of feathers, kicked over sand castles, tortured kittens, pulled the wings from butterflies.

I disliked systemd at first, (because I had to relearn stuff), but undomesticated equines could not drag me back to OpenRC these days. Unless you are deeply familiar with OpenRC there is no earthly reason to start a new system using it.


Thank you for the advice and explanation.

Just before I do the fresh install, could you advise me at on how to do so, while already having rEFInd installed, as I mentioned a couple of replies up? Thank you.


I couldn’t, because I don’t use rEFInd. There are a few threads here on the forum that mention it and some folks that seem knowledgeable about it.


I haven’t used rEFInd so know very little about it, but using grub you don’t have to re-install the bootloader with manjaro-architect if it is already installed.

You just need to mount the EFI boot partition (ie to boot/efi) during the setup steps before base install, grub doesn’t need to be re-installed. You would then need to run sudo update-grub afterwards to re-generate the grub config and menu.

One of the benefits of using Manjaro is its Arch base and that much of the Arch wiki is directly applicable to Manjaro. Not all of it, like drivers and kernel config, but nearly all. It is a fantastic learning resource and probably the best place to look for info when you don’t understand something conceptually… rEFInd for instance…


or systemd



I have just deleted both my rEFInd and Manajro installs, and reinstalled both from scratch in Manjaro Archtiect, this time opting for systemd instead of openrc. Now when I boot into Manjaro, it hangs at “Started TLP system startup/shutdown” until I do a force shutdown by holding the power button. This is the exact same issue when I installed from the iso (as shown here).

This clearly is a problem relating to what I originally had earlier today using openrc, the only difference being that with openrc, I could actually boot into my desktop, but not be able to shutdown. Now I can’t even boot in.

Any ideas? Should I reinstall with openrc again and try to figure it out there?


There is some mention of that same error here on this forum:

Is there a reason you are using Architect rather than one of the officially supported methods?


Probably because of this?

As for the OP. I don’t think the systemd causing this issue, but rather the dual graphic cards in your system. In Architect, you could try to choose option 4 to install all free drivers. Then after installing it, use the fallback initramfs when booting. That way, I hope it will get past tlp startup/ issue shutdown


One of the other people reporting this just went into the bios and shut off the intel video.


Well, there are others who can’t do that since they’re using acer/asus laptop. But I think OP can do that since he’s using Dell XPS…


What graphics driver did you install? Free drivers I don’t think will work (ie nouveau).

If you wish to use your nvidia card I would recommend you select the proprietary bumblebee hybrid driver


or for the sake of simplicity, to get your installed system to boot just, select the intel driver


and the hybrid driver can be installed post install if you wish.

Booting from the ISO I assume you tried non free graphics drivers? I don’t think free drivers will boot with this machine.


You shouldn’t need to re-install your system just to change the graphics drivers installed

Boot into your manjaro-architect ISO and from the CLI chroot into your installed system, where sdXX is your root partition

sudo mount /dev/sdXX /mnt
sudo manjaro-chroot /mnt

Now check which mhwd driver is installed

mhwd -li

I just did this with a Virtualbox Manjaro VM, it worked well.

To install a different graphics driver using mhwd, remove the current one first, then install the new one. For example, if you have nouveau installed and want to replace with nvidia bumblebee

sudo mhwd -r pci video-nouveau
sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee

If you have nvidia bumblebee already installed and want only the intel driver to get your system booting

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-intel

I assume you installed the 4.11 kernel, to check

mhwd-kernel -li

If not then you can install it using

sudo mhwd-kernel -i linux411

Also, for the manjaro-architect ISO CLI you can run diagnostic commands

inxi -Fx
journalctl -p err -b

Pipe the results into text files, mount a USB drive, copy them, and post them here.

You can also check your xorg logs for errors in /var/log. Copy them and pastebin them here too.

Before you do all that piping and copying though, make sure you have the correct graphic driver installed first, and try booting into it.


This may be of help, other users on Reddit with your machine trying to get Live ISO to boot also.

This sounded encouraging…

Ok. I installed Manjaro with Manjaro Architect last night. working like charm now.

I think this is a graphics driver problem, as I mentioned in previous post, but you could always ask these reddit users the installation options they chose.

Bottom line is with this particular hardware system mhwd on ISO doesn’t handle it well currently.

I also found this on Arch wiki, an entry on your machine


just note that Manjaro graphic driver config is done differently in Arch, Manjaro uses mhwd, so take the graphics configuation section as conceptually instructional and not literal.


My Dell BIOS doesn’t seem to have that option.


Someone in my.other thread recommended that I use Architect because of the problems I was having. These new suggestions in this thread seem to say differently though, so I will try again later.


Thank you for the suggestions. I will try these when I am home from work.