Dell Inspiron 15 7559 Install media won't boot



I am trying to install manjaro xfce on my new dell laptop and I am having some difficulties. When I select an option on the boot menu, I see a bunch of scrolling text. Eventually, it gets to a line that reads.
"a start job is running for LiveMedia MHWD script (4m 32s/ no limit)"
with the time steadily increasing. The machine is caught in an infinite loop and I cannot boot the install media. I verified the download and I wrote it using dd. How can I install manjaro on my laptop?


Hi. Probably install script can not load dirver for your graphics card. You can try to select free or nonfree drivers from boot menu. If neither works, it is possible to boot with generic vesa driver in low graphics mode, but you have to add some kernel parameters manually. Please post here if you have tried both free and nonfree drivers and provide your GPU details. You can search the forum for your GPU to see if someone have already asked the same question.


I tried both free and nonfree drivers. The only solution I have seen so far with other laptops by dell is to use a distro with a more recent kernel. I am downloading one such distro but it is a rather concerning problem that the installation media does not work with a 960m.


You can try to boot Manjaro alpha builds, AFAIK they use 4.9 kernel. See the forum announcements section.


Hello, I solved this problem by changing these in grub:


Am also using Dell inspiron 15 7559

Manjaro deepin 17.0.5, how to enter "try before install" desktop